Cannot Run any Job in Orchestrator ( Pending Allocation )

I’m doing Practice 3 of Orchestrator for Developers module of RPA Develper Foundation Training, and when I want to create and run a Job I cannot select any of my robots, the only option that Orchestrator give is “Allocate dynamically”, but then when I push [START] the job is stuck in “··· Pending” / Pending allocation state.
I’ve tried with 1 robot and later with two robots for a process of DEV, and always same result. Could someone help me?

@ricard.gil - Open UiPathRobot in system try and check is the Robot is connected with Orchestrator, if not - pls connect the robot with Orchestrator.
if yes - please do the disconnect and connect it back. Stop/Kill the current job -> create a new job - select specific job and check.

Ensure your Robot is of type Unattended if you want to initiate a job from Orchestrator. This is a recent change to the Cloud Orchestrator. Otherwise start the process from the UiPath Assistant / Agent Desktop.

1 Like

I’ve changed the robot to unattended but it still not appear at Robot list available in “Start Job” window, so my issue remains.
Regarding processes, I have two available in orquestrastor ( with green check) but they don’t appear in UiPath Assistant, that is also connected.

I’ve done this but my issue remains.

can you able to share both start job & robot screenshots?

Both screenshoots attached by email ( I hope these arrive)

Robot1 is not assigned to any of the environments. Pls create one environment through Environments section - assign the Robot1 and check. Robot will be available in Start Job window.
Refer link for manage environments -

No it works. The Environment was created but no assigned to the Robot.


cheers! @ricard.gil

@GBK I have the same problem and environment has been assigned to Robots, but It still can’t work .could you give me any other advise?

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.