Cannot publish a package only templates

I am new to StudioX & have created my first project.

I can successfully run the project from the Run button in StudioX, Now I want to publish the project locally so that it can run from the Assistant.

However, when I click the Publish button the Publish Template wizard begins, not the Publish Process wizard.

Am I missing something?

My project has no errors & runs correctly via the Run button.

Hello Simon,

Maybe by accident when you started you project instead of new project you sellected new template? Or you try export project as template instead of publish

source of screen shot:
Project Templates (

More about publish types you can find here.
About Publishing Automation Projects (

if nothing work, maybe try to send you project so we could investigate it more deeply :slight_smile:

Don’t think I started project as a template. I certainly did re-open it as a local project, not a template.

I am not trying to export as a template, just publish…

Please note I am using StudioX, not Studio, so don’t even see the Export as Template button.


So If I understood correctly you started creating a template , then decided that you wanted a project that will eventually be published and ran from the assistant and you are now stuck on how to convert the template to a project ? If so why not create a new project from the template and then just publish the newly created project ?


Hi Dragos, no I did not start creating a template. I created a project, & cannot publish the project locally so that it can run from the Assistant.


Let’s find a solution , so one that comes to my mind is to publish the project as a template

then create a new project from the template

and then publish that project to Assistant.

PS: you may find it more easy to select to publish the template to local

The other not so elegant solution would be to open 2 StudioX instances and just copy paste all the activities from the template to the new project.

Hope this helps,

1 Like

Thanks Dragos, I used the “not so elegant” solution & that worked for me.

publishing local template & creating new project from that also worked.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.