Cannot Navigate to Client Information page in Academy Assignment 1

arguments
academy2

#1

Hi guys,

This is regarding Assignment 1 in academy2. Just need to know anyone else is also facing the same issue as I am. I have the WIID list, after that I used For Each Row to iterate through the WIID list, and then navigate to the First client info page. But for me I am getting error when executed.

Inside Navigate workflow, I have 2 arguments, lets say arg1 contains url and arg2 contains WIID (which we get from the for loop). I have confusion regarding the direction of argument, so I tried with all directions and ending up with errors.

`

Note
WIID list is of datatable type
arg2 is of datatable type
created a variable var1 (datatable type) in main workflow to bind these two…


Problem with Walkthrough – Calculate Client Security Hash page 10
#2

Hello there,
could you please attach workflow.


#3

Are we allowed to share the workflow in forum as it is related to the assignment 1? :slight_smile:


#4

haha come on mate .:rofl:
only the workflow where error occurs.


#5

forumfinal.xaml (22.2 KB)

var2 contains the WIID list which can be seen from the excel written.
Used for each row with each items in var2.


#6

Hello there,

Datatable.string ?(read.string):thinking: it return empty.

You need to use get row item activity(output WI) inside For each row to to get WI5. and then pass in navigate to url+WI

Are you sure your following walk though template of security hash .
Calculate_Client_Security_Hash_Walkthrough.pdf (944.8 KB)

You can directly filter WI5 item like this.
datatable.select(“Type=‘WI5’ AND status=‘Open’”")
and then loop though each item by for each loop(which give WI5)
No need of creating another excel sheet and reading from it.


#7

But we require WIID right inorder to navigate to that particular client info page?.

By using
datatable.select(“Type=‘WI5’ AND status=‘Open’”") we only filter the table. I made new excel and read range inorder to get the WIID. I went thru the pdf but I didnot found any method to get WIID. So I went for this method.

I am totally confused with this… Thanx for ur quick reply


#8

Here we go.
Main.xaml (56.1 KB)


#9

Hey @ddpadil I did the same like you… There’s no issue with scraping and storing WIID… But the issue is after the For each activity … Can you please share the Sha1 workflow which is to be invoked within this… I am not able to iterate through the hashes. It would be nice if you could send that particular workflow which u have used to copy the hash into the sha1 website.

Thanks in Advance!!


#10

wow, that was a great help. But Not able to type into sha1 website, also only one client info is entered in sha1 online website sometimes. Within for loop all the client info will be extracted right? Or one by one? Like, One client info then corresponding hash., similarly for rest clients.

Do you mind sharing the rest workflow. I have created the rest workflow but when I invoked into yours ending up with errors.

SHA1Online_GetHashCode.xaml (9.2 KB)
Update_Work_Items.xaml (13.0 KB)


#13

wow! that was a great help. Thanx mate. Btb if you don’t mind, where we used REFramework here? :confused::confused: . Also we need to connect with orchestrator also?


#14

LOL. I knew someone gonna flag this :rofl:
any moderator …! you may proceed to delete the post. (bcz i’m not gonna edit this :wink:)


#15

@UnicornStark

Hi all
Hi How were you able to get WI_List out onto the : "Init State ( by passing arguments) I tried to pass as Datarow[] , but i can’t display the count in a write line by using "for each "activity …InitAllApplications(Autosaved).xaml (6.3 KB)
Main(Autosaved).xaml (48.5 KB)
so I can’t figure if any data has come out " ?

InitAllApplication Workflow

the data rows are fetched as DataRow[] and the count is being displayed while in that workflow.
Please see snapshot below

image

Invoke workflow of InitAllApplications

But when I try to get the DataRow[[ out through the invoke workflow I can get the value out onto the main page .

Please see snapshot below.

Main WorkFlow

Please see some more info . in the main workflow the DataRow is not getting displayed.