Cannot Navigate to a particular option


I am trying to execute the following instruction:
login to ACME system 1>>Navigate to Vendors - Search page (click or hover over the Vendors menu item and then click on Search for Vendor); and this will navigate me to search vendor page.

But every time i try automating this process i cannot click on the "search vendor "option it just does not appear because the recording(desktop/web) or any activity fails to capture it and i get errors…PFA the screenshot for referance

Kindly guide me how can I automate this process.


Hi @Afiyah

Use UiExplorer and find selector for Search For Vendor. Then use two click activities first for clicking on Vendors and then another for clicking on Search for vendors


Alternatively you can use hover and click activity together to get the desired result.

Alternatively you can use navigate to activity to directly navigate to search page.


Bonjour @Afiyah
you can use simple click activity to click on Vendors and then you can use another click then use F2 to stop the capturing in the three seconds click on vendors manually to access the search for Vendor menu.
I know when you put only the first click it doesn’t seem to work since you can’t see the menu of search for vendor, but when you have the two clicks it does work.

anyway here is a workflow that does just that enjoy :wink:

Main.xaml (12.8 KB)


1 Like

Hi @reda @PrankurJoshi

Appreciate your quick response!!

I tried doing the first 2 methods mentioned by @PrankurJoshi but as @reda said before when i click on “search vendor” option then press F2 key, after 3 seconds when i want to select it it vanishes… why does it vanish right when we want to select it?
:neutral_face:…its getting hard to capture just that option.

(PFA the screenshot)

@reda Thanks for sharing the workflow. I will give it a try.

Thanks & Regards

Can you use IE for this I think it’s going to work

For vendor click use this

<webctrl aaname='Vendors' parentid='dashmenu' tag='BUTTON' />

and for Searching use this

<webctrl parentid='dashmenu' tag='LI' aaname='Search for Vendor' />


I never gave a try in IE…
Could you please guide me how to add and enable the extension in IE for Uipath

This is the best part @Afiyah there is no extension just use it

@Afiyah you don’t need an extension for IE.
Try with ‘Navigate To’ activity

1 Like

Hi Again @Afiyah
you can use clicks (that’s what I did when I was having my certification) or you can use this also as @guiggs has said


you just need to wait for dashboard to appear and then use it
hope this helps :smile:

Hi again @reda @guiggs

It worked!!:slightly_smiling_face:
The “navigate to” activity worked…
Guess i have to use IE for all the workflows from now on…

@PrankurJoshi @reda @guiggs thankyou so very much for your help and quick responses…



Will try this option too…


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.