Cannot Get Bot Working on Unattended VDI

Hello everyone,

We are testing if we can run UiPath bot on unattended VDI with Orchestrator.
In the attached workflow, we try to open the Notepad application, type into some text, and then click Help > About Notepad (No image activity involved)

Workflow file

Below are the results when we run the bot which is installed on a VDI via Orchestrator:

  1. If we connected to VDI (i.e., VDI window open) —> Everything works as expected

  2. If we disconnected to VDI (i.e., VDI window closed) —> Notepad application is open but then exception. The screenshot taken in the catch block shows the “screen saver” desktop. Then we have tried to use the “Launch Workflow Interactive” activity to call the workflow but still the same exception and the same screenshot.

Just wonder does UiPath bot supposed to be run on unattended VDI? Any thoughts what we could try/check? Thanks in advance.

Our setup
2018.1.2 CE
Orchestrator CE
Windows 10 Citrix VDI environment


Hi @alexch,

you have mentioned that you are using 2018.1.2 community edition then it is still considered as studio and not unattended bot (unless you enter license).
When we talk about (VDI)servers, they are usually unattended. Want to understand, what do you mean by unattended VDI? This is something new for me!

This is also happening to me, I have tried also setting the resolution in bot’s settings, updating it directly in uipath settings, also with Interactive activity, but for some reason activities that has to do with click, type, etc does not work (I used open application and it leaves notepad open but then dies). I get the timeout exceptions or for screenshot object not referenced.