Cannot find the UI element java gui

Hi there

When I run UIpath where I read from a spreadsheet to a datatable and then write the data into another gui (java based) I once in a while get the below error. If I then run it again, then it proceed past the spot without problems.

uipath

My question is why? Is it the gui that’s to slow to respond? or is it an error in UIpath?

Kind regards
Per

Hi @pand

I had something similar in the past with a Java app. I solved it by having a Try-Catch with an activity that fails the first time. I basically placed the Type Into (in your case) in a Try of the Try-Catch with 0 s timeout and an empty Catch that will simply swallow the exception.

This was enough for the very same Type Into activity to work just after the Try-Catch. Please give it a try and see if it will work :slight_smile:

Hi @loginerror

It seems to do the trick. It still fails once in a while, but not nearly as often.

Thanks.

Kind regards
Per

Could you still say your version of Studio and the application that gave you this issue? I will register the issue :slight_smile:
It should definitely be fixed.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.