Cannot find google sheet

Hi Guys, I have installed the Gsuite and GoogleSheet packages, got my keypath and read over the following link many times.

The link is great but when I run my workflow it comes back with “Google sheet application scope: Cannot find the requested object”
I’m using the service account that’s linked to my main email (where the sheet is) and the string listed under “service account keys” at console.developers.google.com for my password in the Google sheet application scope.
I have tried the url from the google sheet page, a shareable link and the name of the sheet in the “input” of my google application scope but it still won’t find the google sheet.
The file i’m using for my KeyPath is a .json but i’ve also heard of P12. but I have no idea on which one I would need or how to change it.

I just don’t know what i’m doing wrong or what else to try. Any help would be very much appreciated.

Ryan.

Hi , Please Use the Service Account , which is linked to your Mail ID that you used to register for the Uipath studio and try
The service account key will work with Both .Json and P12

Please refer to this Link
https://jan-lolling.de/talend/howtos/google_service_account/create-a-google-service-account.html

1 Like

Hey guys, I had used a google sheet application scope rather than Gsuite application scope. Silly mistake. This tute is great for beginners too https://www.youtube.com/watch?v=BnvhFOwKtOA&t=708s

Thanks for replies. Hope this helps other beginners not make easy mistakes.

1 Like