Cannot encrypt UiPath.Orchestrator.dll.config section

Hi all,

I encountered the problem that I’m not able to encrypt a section from the UiPath.Orchestrator.dll.config, namely the “connectionStrings” section, when installing v22.10.
Before in v22.04, it always worked. Encrypting the “secureAppSettings” works just fine.

I’m executing the comment as it is documented here, only difference being the “-pe” parameter is “connectionStrings” instead.

Has anyone else experienced this? If so, have you found a solution for this?

Any feedback would be helpful, thanks in advance! :slight_smile:

Hi @Lucca

This might help you


Hi @Anil_G,

thanks for the hint!

I’ll try that and let you know how it went.

1 Like

Hey @Anil_G,

sorry for my super late reply, but the topic got lost up.

The KB article you sent me works indeed, but does not encrypt the Orchestrator.dll.config, for whichever reason. As far as I understood, the regiis.exe tool only encrypts Web.config, but I might be wrong on that.
Still, I tried it today again for the last 22.10 subversion. The command with the “connectionStrings” section indicated worked, but didn’t encrypt the section.

The command was constructed as follows, exactly following the KB article you sent:

“aspnet_regiis -pe “connectionStrings” -site “UiPath Orchestrator” -app “/” -prov “RsaProtectedConfigurationProvider””

Did I do anything wrong, or have you come across a different way to encrypt the aforementioned section the the Orchestrator.dll.config file?

Hi @Lucca,

Were you able to resolve the issue ?

@Lucca can you try "C:\Program Files (x86)\UiPath\Orchestrator\Tools\Cli\UiPath.Orchestrator.Cli.exe" protected-configuration -pe "connectionStrings" -site "UiPath Orchestrator" -app "/" -prov "RsaProtectedConfigurationProvider"

I saw that you’re still using aspnet_regiis, which has been superseded by UiPath.Orchestrator.Cli.exe as per UiPath documentation. thanks for you input. That command is the one I’ve been always using, as I mentioned in my initial comment, and that started to return an exception from the 22.10 version on. That’s why I tried to fall back to the aspnet_regiis tool. Both are not doing the trick though.

What was the error that you received?

An exception indicating that the section could not be found in the file. I made sure that I made sure that this is not the case by copying the section name from the file to the command. I unfortunately don’t have a screenshot or text to the message because I don’t have permanent access to the environment. I can try to get it next week though.

Hi @Lucca,

We were facing a similar issue while encrypting the orchestrator.dll.config for 22.10 version. After encrypting the SecureAppSettings successfully, we were not able to encrypt ConnectionStrings.

Our issue was, after initial encryption or decryption is successful, the “configsection” closing parameter position is getting misplaced in the dll.config file. So the next encryption/decryption fails saying “Object reference not set to an instance of an object” as below.

Before SecureAppSettings encryption,

After SecureAppSettings encryption,

We had to move the closing configsections to correct position, save the dll.config file and then run the next encryption command which was the connectionStrings. It was successful. May be you might want to check the same in your dll.config file. If the position is getting misplaced after every encryption/decryption, you need to re-position it correctly and run the next command.

Let me know if this helps.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.