Cannot create unknown type : Issue in running the job from another environment

Folks, when i try to run my package through orchestrator in the different machine/environment i am getting the below error and getting faulted. I tried to run through agent as well… No luck? Any idea on how to resolve the issue?

Cannot create unknown type ‘{}UiElementExists’.

RemoteException wrapping System.Xaml.XamlObjectWriterException: Cannot create unknown type ‘{}UiElementExists’.
at System.Xaml.XamlObjectWriter.WriteStartObject(XamlType xamlType)
at System.Xaml.XamlWriter.WriteNode(XamlReader reader)
at System.Xaml.XamlServices.Transform(XamlReader xamlReader, XamlWriter xamlWriter, Boolean closeWriter)
at System.Activities.XamlIntegration.FuncFactory1.Evaluate() at System.Activities.DynamicActivity.OnInternalCacheMetadata(Boolean createEmptyBindings) at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors)

Hi @Pradeep.Robot

Please make sure that the packages feeds are properly set for the robot on that machine. I sometimes get similar things when I published a process with beta packages to a robot that has the beta feed disabled :slight_smile:

Can you please guide me on how to check the same? It works when i copy all my local folders in to that machine. but, i dont want to happen that way. it is not working in certain conditions… for eg, uipathRuntime.msi is installed in citrix servers and supported in ui.automation 19.11.1 in my project. if the same project in other machine, i am getting error that the extension is not installed.

i believe, the package is still not identified. is there anything should i need to check/change?

Of course, please see this article:

1 Like