Cannot create unknown type 'AppendRange'

I am trying to read the emails from Outlook by using “get outlook mail messages” activity. On local I was able to read the emails but not on Terminal Server. I am getting following error saying that “Cannot create unknown type '{http://schemas.uipath.com/workflow/activities}AppendRange’.”

PFA of screenshot of error. Also I copied every dependency file from local to Terminal Server. There is no issue with dependency files. Any help here would be highly appreciated.

Hi @srinucslt,
Get Outlook Mail Messages activity need to have outlook application opened and user logged into account to be able to perform the action.

1 Like

@Pablito I already tried with outlook open and user logged in. No luck.

@srinucslt I’m trying to understand what in this situation the Terminal Server means. If it’s machine (whatever VM or physical one) running on Windows OS you should be able to just install Studio/Robot. Then after opening/starting workflow (with Outlook opened on this machine) all should work fine. Can you put little light on this cause probably I don’t fully understand the background of what you are trying to do. Please give more details :slight_smile:

1 Like

@Pablito Here Terminal server means virtual machine i.e RDP. I have Studio installed on Local with version 2018.2.3, Robot & Orchestrator 2018.4.1 installed on Terminal Server. Moreover we are using Windows Server 2012 R2. I tried running bot with outlook open, even then no luck. Coming to first step in my use case, Bot needs to open Outlook, read emails and scrape the information from it and store it in excel. Its working fine on Local but getting issues on Server. I copied all the dependency files and packages just like Local machine. Bot is failing immediately after 1 sec of execution. Could you please help me here? Highly appreciate your response here.

@srinucslt,
From what you are saying it seems that for workflow deployment on VM you are using only tandem of Orchestrator and Robot. It might be that (if you are using some additional feeds in your workflow) it throws an error because your Robot don’t have accesses to the feeds and is unable to start it. Please take a look here:
https://robot.uipath.com/docs/about-the-activities-feed
The other thing which is going through my mind is that it also might be that some libraries are blocked by program/firewall or something.

1 Like