Cannot connect to packages feed the deployment settings may be invalid

Hi, I had the same problem and I cleared that. I deleted some unused files file from the project. i.e custom output log files.

Hi Guys I solved this problem like that : When I wanna publish my project in studio I chose “Custom” and picked up any Folder to send it this folder.
This is the second step : Open your orchestrator platform and pick up the
Processes->Packages->Clik Upload->Browse and pick up file your published before as nupkg
It will probably be published.

I do as u said and still got that error :frowning: Any idea?

If you have documents in your project folder so delete all of them and then go project.json file and find “projectVersion” and make it “projectVersion”: “1.0.0” then publish it so it will be published.
Have a nice day.

I was experiencing the same error, I resolved mine because I had a file without an extension in the folder I was trying to publish, once I rectified this, I was able to publish.

Hi All,

I was facing same issue. Below are steps I perform and it resolves issue.

  1. Remove all files which are not used in your automation or generated through automation from your project folder.

  2. Publish project again.

Hope this will resolve your problem :slight_smile:


1 Like

Hi everyone,

I am still receiving this error after deleting previous package files (and checking the file size of the new package to make sure it is not too big). I am set as admin for my machine as well.

I have also tried deleting all packages, the process, and the bot from Orchestrator in order to start completely fresh.

I am still receiving the error when I try to publish both with options “orchestrator” and “custom” in the Publish window.

I have looked into the settings in Studio, but I’m not really sure what I can edit to resolve this problem.

Any ideas?

Thank you in advance!

Hello guys, i don’t know if you find a solution but for me the problem was that the new version that I want to publish it was having the same version like the version already published in Orchestrator. So in my case in project.json the version it was: “projectVersion”: “1.0.2” and in the Orchestrator it was the same version 1.0.2, already published.
I change the version in project.json and I was able to publish the process without problems or errors. :slight_smile:
I Hope this Help!


Any solution?

Just wanted to throw in my issue/fix for this problem… My process had created during testing a file with no extension on it, this file was preventing the publishing to Orchestrator for some reason. I’m not sure why it’s throwing this error for something like that, but I just deleted the file and was able to upload without issues.

I was having this problem during the week. In a call with UiPath Technical Support, i was told that a file in the path should be causing comipling error, and beacuse of this, it wasnt able to publish.

The solution was to create a backup folder with all your project, and in the other folder, delete one file at a time, and try to publish again. In a certain shoot youll be able to identify wich folder/ file was responsible for not letting you publish.

In my case was some weird .txt content that didnt let me published my project.

Hope that this be hellpfull to someone!

1 Like

Could you please share

  • studio and Orchestrator version?
  • Files/folders that you deleted and got the issue resolved.

I tested with 19.10 and could not replicate this even with a .txt file or no extension file.


I was having the same problem. I tried removing the project.json file but did not help. In the end it turns out my project version was colliding with the version allready in orchestrator. In Orchestrator my project version was: 1.0.117, so I edited my project.json file to be the same version.
It solved my problem!

It was related to artifactory
there was api key which needs to be changed

Hey @loginerror - I’m having this problem with the cloud version…if I use internal I get the same error as the original feed. If I change to external settings and use the api key I get a slightly different error message

I also created a brand new library - so this is nothing to do with any files that are or aren’t in the library. I can publish packages with no issues. I am an admin on Orchestrator.


Could you quickly clarify when does this error occur? This topic is about the error during publishing of the project to Orchestrator.
Do you mean that you can publish the package locally without issue but you cannot to Cloud Orchestrator?

This is about publishing a library (sorry if slightly wrong thread but closely related).

Your messaged helped me to get the greyed out Orchestrator option to work because I changed Host to Tenant, but the error message appears when I click publish.

Wondering if it’s a whitelisting problem to the myget url??

Additionally, this is the error message …


I found one topic here, could this be it (the size of the project)?

Does it have any more info in the Details of the error?

removed this detailed error…as not very helpful.

Just to be on the same page, could you post a screenshot from your deployment page in Orchestrator instance your are connected to?