“Cannot communicate with the browser, please check the UiPath extension” error when running from Orchestrator

Hi Ovi,

i am facing one problem.

"Cannot communicate with the browser, please check the UiPath extension"

in disconnected mode(local) its working fine but while running through orchestrator few time i am facing this issue.

can you please help me

Do you know why this issue coming. i am using chrome browser.

Studio/Robot version?
Are you using the same user for robot (in orchestrator) and for running locally?
chrome version?

2017,Chrome latest version

if you run from robot tray, is it working?
from orchestrator, is it failing every time or sometimes?

Not all the time.

right, it is a known issue in 2017.1. can you try with 18.1.1 ?

UIPATH.core.Activites, Cannot communicate with the browser plz check ui path extenshion

How to solve from uipath 2017 version itself???

you can add a try catch, and if you have this error, try again the Open browser activity

Hi @Gabriel_Tatu,

Is there any other way to solve this one.
Actually i have already done the same way.

Regards,
Arivu

it should be fixed in 18.1.1 this is why i ve asked you to upgrade

Hi, I’m experiencing this error. I’m using Studio 2018.1.1.

It runs smoothly when run/played in robot tray but in orchestrator schedule, it’s failing.

Execution error : UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension.

Need immediate advise please…

Thanks,
Gerlie

Can you remote the machine using the same user as robot and open browser? If there is a pop up coming up it will give that error

Hi Gabriel,

Yes, i can. Actually, as of the moment, the issue was resolved. I am not sure what resolved it. I did a lot of setup before that didn’t work. Specifically, I removed UiPath extension from Chrome and reinstall, enabled access from incognito and allowed access to file. Wasn’t working, I even renewed license of my community edition of UiPath Studio, restarted both Studio and Ui Robot. But the last thing I did was restarted the Windows VPS where it is installed and it worked perfectly.

Thanks for the response,
Gerlie

Hi all,

I am not able to open browser and so website is not launching.
I am seeing the message “cannot communicate with the browser please check the uipath extension”

I added extension and restarted browser ‘Chrome’ but getting same issue.

Chrome version - 68.0.3440.106(official build)(64 bit)
UiPath studio - 2018.2.3

Please help me. Thanks.

Install Chrome 32 bit version, it should working fine.

Entra a la configuracion de la extension y verifica que este activada la opcion “Allow access to file URLs”

Hi,
Did you figured out the problem for that, I am facing same issue, "Unable to communicate with the browser Please check the UIPath extension "

Thanks,
Shaik

Hi,
I have the same problem, "Unable to communicate with the browser Please check the UIPath extension "
I tried installing Chrome 32 bit and and reinstalled my UIPath as well but still I have the same issue.

Thanks,
Shaik

Hi,
Did you figured out the problem for that, I am facing same issue, "Unable to communicate with the browser Please check the UIPath extension "
UIPath version - 2018.4.4

Thanks,
Shaik

Please refer the link , solution is provided in post #6
Link -. Internet Explorer Problem
Hope it will fix your problem.