Cannot communicate with Internet Explorer browser

browser
studio
p_qa
web

#1

Hello,

I am getting the following error message while I am trying to open an IE browser:
Main has thrown an exception

Message: Cannot communicate with Internet Explorer browser.

Source: Open browser

Exception Type: BrowserOperationException

I have tried executing command: regsvr32.exe oleacc.dll. Also, i have checked the Windows Options and IE is already selected as advised.

Please let me know what can be done apart from this?


Can't communicate with internet explorer in navigate to
#2

Hi,

Please try to reset your IE and check if this works.
Steps to reset IE:-

  1.  Click Start, please type "inetcpl.cpl" (without quotation marks) in the Start Search bar and press Enter to open the Internet options window.
    
  2.  Switch to the Advanced tab.
    
  3.  Click the Reset Internet Explorer Settings button.
    
  4.  Click Reset to confirm the operation.
    
  5.  Click Close when the resetting process finished.
    
  6.  Uncheck Enable third-party browser extensions option in the Settings box.
    
  7.  Click Apply, click OK.
    

Then try using the UiPath Studio.


#3

It is still not working. Any other way around to work on this?


#4

Hi, @nesachdeva

Have you ran that dll with Admin rights, Please do that with admin rights…:slight_smile:

Since I got same problem one month back executed that dll with admin access has revoked me…:relaxed:


#5

Yes i ran it with admin access.
I have found out a work around for launching IE without any trouble.

Step 1: Enter Win+r using hotkeys
Step 2: Enter “iexplore.exe” or even the entire URL
Step 3: Click OK

Further using all the UIAutomation actions, most of the tasks like click, enter, capture etc can be performed on the same.


#6

Can u share ur xaml?


#7

Hello All,
Did you find the solution?

I have the same problem with IE, but I have noticed that is something in the computer since the same artifact works in others computers and I have created a workflow just with the Open browser and still showing the same error.

Also, UiPath was running correctly 2 hours before that.


#8

Hi all!

Have the same issue with IE and Firefox. IE window opens with about:blank page by the UiPath and error occurs. I’ve tried to treat it by executing of “regsvr32.exe oleacc.dll” and by resetting of IE. I guess it is not linked to browser type, but with enviroment (.NET Framework version or Windows 10 settings).
I’m using a Win10 Pro and .NET Framework 4.6.2. Checked this issue using UiPath Studio 2017.1.6522 and 2016.2.6402.

By the way the Chrome behavior is a little bit different . It opens with URL specified in UiPath but same error in further.


#9

Hi, could you please tell me whether your issue is resolved? i am facing the same issue now. i need a pathforward.


#10

I’ve solved the problem by downgrade of .NET Framework after patch KB4033393 (.NET Framework 4.7.1) has been uninstalled !!!