Cannot Automate Remote App : Mismatched UiPath Package Versions

How to troubleshoot error "Cannot automate remote app: mismatched UiPath package versions" ?

Issue Description: When trying to automate any Citrix based application with the help of UiPath Remote Runtime component, it fails with the error : "Cannot automate remote app: mismatched UiPath package versions"




Root Cause: When a process is built or executed, it is needed to use a UiPath.UIAutomation.Activities package which is compatible with the deployed driver version of the UiPath Remote Runtime. The driver is represented by the UiPath dependency of the UiPath.UIAutomation.Activities package. If the UiPath dependency and UiPath Remote runtime components are non compatible, such error is seen.


Resolution: The UiPath.UIAutomation.Activities package contains compatible driver versions for the UiPath Remote Runtime. Refer to the Side By Side Support for more detail.

1 Like