Cannot access ML Skill for Document Understanding

Hi together
I’m working through the Document Understanding chapter in the academy. However, I cannot get the ML skill running in the data extrction section. I’m using the community edition.

The steps are pretty clear

  1. Generate an API-Key: Done

grafik

  1. Drag’n’Drop Activity and fill in Endpoint and API key and choose the skill

I’m not able to choose the ML Skill. I used the offical endpoint “https://du.uipath.com/ie/invoices” and I used the one from the course “https://invoices.uipath.com/
I cannot go on whatever I tried

I studied the docs, the course, the forum. I tried to switch the package version but nothing helps.
I don’t see any mistakes.

By the way, the UiPath Document OCR activity works fine with the appropriate endpoint and the API key.

grafik

Thank you for your help
Enrico

Hi, Enrico!
To answer your first question, the ML Skill parameter is mutually exclusive with the endpoint. This means that you should either use the endpoint OR the ML Skill.
If you want to know more about ML Skills, you can check out this page: ML Packages. Basically, the ML Skills are pre-trained models which you can deploy and re-train in AI Center, and then use them in your workflow. Also, the ML Skill drop-down from the activity is populated when you have one deployed in AI Center and your robot is connected to the tenant on which you have the AIC instance (it has nothing to do with the endpoints).
Regarding the error you received in the Configure Extractors wizard, please make sure you:

  1. Click the gear button (below the Minimum Confidence input) => the Get Capabilities window is displayed
  2. Here, enter the endpoint and click OK => you are back on the Configure Extractors wizard where you will see the right side populated with drop-downs
  3. Now you can select the proper mappings from each field

Hope this information helps!

Cheers,
Adi

Thanks for clarifikation. Skill needs to be empty in my case.