Can someone explain what is Anchor in simple words?

When I try to record Basic or Desktop I am receiving a message saying “Do you want to use the Anchor?”.

What is this message is for? Selecting or denying Anchor activity is getting recorded and not executing while running the sequence or flow chart.

Please explain how to use this Anchor tag.

Please see the attached screen to see message i am receiving

This should be used when a reliable selector is not available.It is more efficient when your unable to find the particular field on the UI Element so in that case you choose to find the relative element which helps the UiPath to identify the element next to your relative element.
*You can use delay (F2) while recording to avoid using anchor base and click on the field .

Please go through this for more reference.


Thank you Dilip for a quick response. Can you explain with any example to showcase the Anchor Base purpose?


1 Like

Even i am getting ‘Use Anchor’ popup everytime i am using Recording with Basic or Desktop.
It ends with error while replayed.

1 Like

Hi @amitsa

What Studio version? And could you please specify what are you trying to record? A screenshot of the error would be useful for us to investigate further.



The version I am using is Uipath 2018.1.4

I am trying to perform Basic and Desktop recording in a Notepad.

Whenever i am going for a Font change a get the ‘Use Anchor’ popup .

I am not feeling comfortable using F2 and pause.

Inline image


Amita S

Hello, I have exactly the same issue.
Have you solved the problem ?

Studio 2018.2.3
Community edition
Running in a VM Windows 10 pro, last update OK
Hypervisor : Virtualbox on Linux

Any solutions?? Facing the above issue too.

Hello, I’m also stuck in the Foundation Phase training with this exact issue. I’ve tried some of the previous suggestions regarding pausing the recording but to no avail. Any official update?

Also version 2018.2.3 Community Edition.

i am still having the same problem…but haven’t got any solution yet

What is the problem you have?


this…i started with recording and when i hit any tabs like file or edit the Anchor problem pops up

just hit no and mark on dont show again