Can not install msi on Server 2012

I have got installed community version 2021.4(exe) successfully on windows server 2012R2.
These days it must be updated to 2021.10(msi) automatically. But the update is failed, 1625 error is reported. I can not solve it according to the guidance. Please help. Or please tell me where to download exe version.


Welcome to uipath forum

Go to where sign up and once logged in you can see an option to download uipath in the front page itself

Before installing the new downloaded one try to uninstall the previous version and install this

Cheers @wjian_991

Continuing the discussion from Can not install msi on Server 2012:

I have tried this, but it does not work

As the jpeg, all are not configured(in Chinese)

These steps would help you resolve this


Sorry, I have tried the MSI.

Even use the command line. “MSIExec /a *.msi”. It failed at the last step after seems copied a lot of files.

Here is part of log.
MSI (c) (80:70) [13:48:21:783]: MSCOREE not loaded loading copy from system32
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘TransformsSecure’ is 1
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘DisablePatch’ is 0
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘AllowLockdownPatch’ is 0
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘DisableMsi’ is 1
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘AlwaysInstallElevated’ is 0
MSI (c) (80:70) [13:48:21:830]: User policy value ‘AlwaysInstallElevated’ is 0
MSI (c) (80:70) [13:48:21:830]: Running product ‘{5A0DB374-E37B-40A9-901A-5D45D82A79C0}’ with user privileges. DisableMsi policy is set to or defaulted to 1. This is the client and the user does not have full admin token. Evaulation is delayed until after credentials provided. This install could still be blocked
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘DisableLUAPatching’ is 0
MSI (c) (80:70) [13:48:21:830]: Machine policy value ‘DisableFlyWeightPatching’ is 0
MSI (c) (80:70) [13:48:21:830]: Looking for storage transform: 2052
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2205 2: 3: Patch
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2205 2: 3: PatchPackage
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2262 2: _Tables 3: -2147287038
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2262 2: _Columns 3: -2147287038
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2262 2: Media 3: -2147287038
MSI (c) (80:70) [13:48:21:830]: Note: 1: 2262 2: File 3: -2147287038
MSI (c) (80:70) [13:48:21:830]: TRANSFORM: ‘PatchPackage’ table is missing or empty. No pre-transform fixup necessary.

But I can not find the key of ‘DisableMsi’ and ‘AlwaysInstallElevated’ in regedit.

Did you try after uninstalling the previous version

Yes, of course.

It looks like some system policy is blocking the installation
Is it your company machine or your own


Company test machine.

I have got the administer permission.


Check below for your reference


There was as security policy enabled in the system which is blocking to install



Check below post for your reference

Hope this may help you


I have installed the studio under administrator account. But can I use as another account? When I tried to select standard alone option, no community version option appeared, only add license key option. This is not happened on administrator account.

Do you mean Stand alone license option?

That will surely require a license and community version doesn’t give you that.

If you mentioned that, opening UiPath Installer as a normal user (not admin) then the option for Community → the Installer is different for that, can you please check what msi you have downloaded?

Below doc has a section mentioning the different types of MSI files for all UiPath versions.

Where is the doc you mentioned?

Admin install/use OK. Community license 21.10.3.

Normal user, can not install, find and run, not community option can be selected.

This is the document I was referring to

I checked and couldn’t see the same behaviour with the msi installer