Can not indicate windows form item on Microsoft Dynamic AX

Scenario: We have windows form application which is written by Microsoft Dynamic AX but we cannot use UIPath to indicate item on this application. Is there anyone know about this issue, please give us some advices

OS Version: Windows Server 2016

Hello there ,

I think UIPAth is compatible with Microsoft Dynamic.Are you using 2017 edition?
If nothing works then you need to go with image automation.
@Gabriel_Tatu any thoughts on this? :thinking:

Hi @ddpadil,

Yeah, I am using 2017 edition.
I am trying to find solution for indicating UI element on that app because my customer don’t want to use image automation.

Thanks and Best Regards,
AnhTH15.

Did you try with UiExplorer ?

Yeah, I tried UiExplore but it didn’t work.

Hi AnhTH15,

Can you please collect some low level traces and share the .etl file so we could investigate? In order to do so:

  1. enable low level tracing:
  • UiPath.settings file - LowLevelTracing parameter set it to true
  • or from command line UiRobot.exe --enableLowLevel
  1. use UiExplorer to select something in the app
  2. disable tracing:
  • LowLevelTracing parameter set it to false
  • or from command line UiRobot.exe --disableLowLevel

You can also open a ticket(attach there the .etl file if you don’t want to share it public on forum):

1 Like

Hi, ovi, did you find the solution for this problem? Because Uipath robot gets unstable while automating Microsoft Dynamic AX in background: sometimes elements are not being found, sometimes type into activity doesn’t work as should. Changing properties of activities doesn’t help much.

Hi @rytis.k

I have been automating a couple of workflows in AX.

Here is a couple of my findings

  • Sometimes it helps to click somewhere “random”, to ensure that UiPath is really attached to the windows.
  • Use hotkeys whenever possible.
  • Use find element to ensure elements are appear. Put them in a retry scope for more reliability.
  • Use tab to skip through fields or buttons. (hotkey)

Hope you managed to work it out.