Can not connect to Orchestrator

Hello!
I have a community license that mean that i can create 2 processes into orchestrator.
I created a new machine and robot in orchestrator.


When i trying to set up orchestrator on pc i got this:

That means “Status: No license”
And after publishing a process via UiPath Studio i got this message:


“The computer key is connected to another computer”

What that mean and how can i fix it?

Please assign your robot to one of the environment and then try to connect @Jom4ick

Fine
lets go one by one
–first the machine is not same
kindly mention the same machine name as per in your machine where you want to connect the robot and execute the process, while creating ROBOT in ROBOT TAB in ORCHESTRATOR

–and to find the machine name go to START -> search as UIPATH ROBOT -> click on the settings option and there we can find the machine name. use the same while creating robot in orchestrator
image

then we need to assign that robot to a ENVIRONMENT

–for that go to ROBOT tab and in that go to ENVIRONMENT tab and create a new environment and add the robot Test to that environment

hope this would help you
kindly try this and let know for any queries or clarificaition
Cheers @Jom4ick

How can i only chose the Demo Environment

Is it correct step?

@Palaniyappan
Ok i found the Environment tab. Connect robot to this environment but now i have other exception:
The robot does not exist

1 Like

yah thats possible and you are correct
click on that DEMO ENVIRONMENT
there for an environment we got this
click on MANAGE

then click on the robot we need to add and then click UPDATE
image

Cheers @Jom4ick

@Palaniyappan i have edited my message.

if you are trying to run that bot from orchestrator then bot should of type UNATTENDED
change that in the ROBOT tab and update it

Cheers @Jom4ick

@Palaniyappan still the same

ok
but i m not able to get the exception here being in different language
image
can you translate it…:smile:
sorry for that
@Jom4ick

@Palaniyappan

Error: RemoteException wrapping UiPath.Service.Orchestrator.Clients.OrchestratorHttpException: Robot does not exist.
в UiPath.Service.Orchestrator.OrchestratorClientExtensions.d__3.MoveNext()
— End stack trace from previous location where exception occurred —
в System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
в System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
в UiPath.Service.Orchestrator.Clients.OrchestratorBaseClient.d__6`1.MoveNext()

Something like this :smiley: and it repeats.

1 Like

Hello @Jom4ick , change your Orchestrator URL. See the below post:

1 Like

kindly check once with the username and domain mentioned inthe ROBOT tab
to get the correct name go to CMD window in our machine and type as WHOAMI
which will give us the domain and username
mention the same in the ROBOT TAB for DOMAIN\USERNAME field…
kindly update it and try once

Cheers @Jom4ick

@rmunro Still Robot does not exist

@Palaniyappan yes it works. Robot now connected.

After that i published my process via UiPath Studio with default settings:

But i can not find robot in UiPath Robot.

Oh. I needed to create new process in Orchestrator. Now it works well. Thanks a lot!
@rmunro
@Palaniyappan

3 Likes

Great
Cheers @Jom4ick

1 Like

had some issue like this, whoami worked
for some reason when used full domain
machine.company.com/user - did not work
machine/user - worked

2 Likes

Hi
Welcome to uipath community
Kindly mention what the clammed whoami gave for the Machine which we are going to connect to the orchestrator

Cheers @Rayudu_Addagarla

Where to provide this information.?
could you guide me/ i have installed the UIpath studio but could not sign in