Can not change UI Exlorer language

Hi everyone,

I am using Windows 10 Japanese version,
but I want to use UiPath Studio in English.
I change the language from Japanese to English in UiPath Studio settings,
but it is still display Japanese as interface language when I use UI Exlorer even though I open it by UiPath Studio.
I wonder if there is any method to change the language in UI Exlorer.

Hi @wusiyangjia

After you change the language from Japaneese to English

did you restart the Studio

Thanks
Ashwin S

Hi @AshwinS2

Thanks for your reply,
restart the Studio doesn’t work.

Hi,

In my environment (see the following), language settings for UiExplorer is automatically changed along with UiPath Studio.

  • Studio 2018.4.6 on Win7 Pro (x86) Jp.
  • Studio 2019.10.1 CE on Win10 Pro (x64) Jp.

There might be something wrong with UiPath settings…

Regards,

Hi,

I just found a case to reproduce the issue.

UiExplorer is included in “UiPath.UiAutomation.Activities Package”.
If you launch UiExplorer.exe which version is not compatibility with “UiPath.Service.Host.exe” or “UiPathStudio.exe”, the language forced to OS settings.
So, can you check the version of UiExplorer.exe and studio?

img20191209-1

Hope it helps you.

Regards,

Hi @Yoichi

Thanks for your reply, below is my evidence.

Hi,

Thank you for sharing.
It seems there is no problem with the versions.

As workaround, can you run the following exe directly? 19.x.x should be 19.7.0 or lower.

C:\Users\[UserName]\.nuget\packages\uipath.uiautomation.activities\19.x.x\build\UiExplorer.exe

Regards,

1 Like

Hi,

In the uipath.uiautomation.activities folder, I have 18.4.3, 19.2.0, 19.7.0, and 19.10.1 versions.
And I found that only 19.10.1 version’s UiExplorer is Japanese,
all of the others display in English.

Thank you

Hi,

It’s been a while so I don’t know if you guys solved the issue but i will reply anyway in case someone came across the same problem.

I had the exact same issue, my Studio was English but UIExplorer was kept opening in Turkish. Regarding @Yoichi answer I tried to delete language (TR) folder from C:\Users\[UserName]\.nuget\packages\uipath.[uiautomation].activities\19.x.x\build\ and solved the issue.

In this case, I think if you delete Ja folder it would resolve.

Before

The Folder I deleted

After

Hope this helps.

1 Like