Can anyone solve this please..?

i am using the practice reframework calculate client security hash project and its giving me this error at Get Transaction Data State, i think it cant go past the “if” activity


Can you share error message? (Please hover mouse cursor on the red icon)



you need to change the condition in if activity


1 Like

But the purpose of this if activity is to only check if the data table has been ran for the first time

did that same error man


ok, the error is saying you are not passes the arguments correctly can you check once

object reference not set to an instance of an object means any argument or variable is getting null values

can you check

Practice-REF-Calculate Client Security (1.0 MB)

i checked i cant find any discrepancy can you please check i have attached the file

Hey @Jai_Pande

The error is happening because the datatable has not been created. As you said:

Try this, change the condition to:
io_dt_TransactionData is nothing


You can only reference the row count of a datatable after it has been created.



1 Like


bro the issue is because of the condition

as you are passing the data to io_dt_transactiondata at first it is not having any data

so use the same condition which is provided by @Steven_McKeering

Hi @Jai_Pande ,

If the Datatabe is not initialised, it will give out the error as shown in Screenshot. So another alternate would be to initialise the Datatable that you are passing as argument like below :

dt_TransactionData = new System.Data.Datatable

This could be assigned in the Default Value or at the beginning of the workflow (First Run Block - If using RE-Framework )

Voila! it worked man thanks! now i am facing another problem when i use get text activity to extract clients id and country and name i am getting the error that,

can you please have a look at my xaml it would be of great help !
its attached above

@supermanPunch @Gokul001

Also i am using alot of “Use App/Browser” and inside of them i dont know where to change this “Open/Close” activity and where not


@Jai_Pande ,

Could you double check on the Project File sent ? Unable to find the exact activity with that name and the Log Message before that as well, Is it an updated version that you have sent and not the same one as used in the Error Screenshot ?

no no i have sent the same not updated brother, you can find the get text activity in process block, also when and where to use these open/close properties of “Use app/browser”, please help

Take a look at this video on how to use Ui Explorer:

Practice-REF-Calculate Client Security (1.6 MB)

@Jai_Pande ,

As already mentioned by @Steven_McKeering , the Selectors use are not valid and hence they are throwing out errors. Always check with UiExplorer is the clause that we would require to perform and pick only valid and stable attributes for the Selector.

Also, Would suggest to use Strict Selector whenever possible. We do see the usage of Fuzzy Selectors and also always check with UiExplorer if there are any better attributes that you can use for identifying the elements. The Selector is not proper and hence it is able to identify.

1 Like

The Use/App Browser is always opening new windows to process, i need to work on a same tab/window, maybe this can be the cause as well, should i choose always open and never close option?