Can anyone explain me how to use orchestrator assets FOLDERS in Studio?


Can anyone please explain me (not merely linking to other forum topics as, believe me, I’ve already tried searching for my problem but couldn’t get a proper answer) explain me how I’m supossed to work with folders in assets and access them when working with the “Get Credential” activity?


I’ve created the folder you see in the picture, JPI_Pagaments blah, because in the Default one (the one I covered in green) there’s already a bunch of assets, it’s becoming unmanageable and I want to start keeping them separated amongst different projects, then keeping the commonly used ones in the Default.

As I understood, when I wanted to use the asset(s) in that folder, I should call the implied asset (which, in my case, is of type credential) I should use the “Get Credential” activity specifying the
linked folder name in the “Orchestrator Folder Path”.

Yet al I get is the “Folder does not exist or user does not have access to the folder. Error code 1101; Asset name: blah” error.

Folder obviously exists, and I think I’ve granted the proper access permissions to my user:

Both in “Account & Groups” and in "Machines:

And in Studio I’ve tried switching to both the supposedly shared folder and to the “general” account one (the one you see with a “@” in the middle I’ve obfuscated in every screenshot; that’s my account), but I always keep getting the same error.

Captura de pantalla 2023-11-20 145332

Can anyone tell me how in the world is this supposed to work??

Hello @pere

  1. Check the accuracy of the folder path specified in “Orchestrator Folder Path” property.
  2. Verify Orchestrator settings and ensure correct API access.
  3. Double-check folder permissions in Orchestrator for the user.
  4. Try using the full path without the “Default” keyword.
  5. Recreate the credential asset within the specific folder.
  6. Check Orchestrator logs for detailed error messages.
  7. Ensure UiPath Studio version is compatible with Orchestrator.

Thanks & Cheers!!!


  1. Already triple-checked before posting.
  2. How am I supposed to check that? I have always been able to use credential from Orchestrator in the default folder.
  3. The permissions I gave to myself are the ones in the screenshots above.
  4. What you mean? I’m not using any “Default” keyword anywhere; I don’t get what you are referring to.
  5. The credential asset is inside the specific folder, of course.
  6. I don’t know where to check this.
  7. I have always been able to use credential from Orchestrator in the default folder.

Does the user have the Read Assets permission?

I wonder where I set this.
But as this is an Admin user and I have access to the main or default folder and it’s the same user who created the folder, I take for granted he has.

In case you meant this…

So I’ve been struggling for days about this with no success. I’d great if someone from the staff would add some light.

In my attempts, I’ve discovered something suspicious: in Tenant → Machines → Installed Versions & Logs, there’s a reference to my work desktop computer, but what looks weird is the “Status” appears as “Disconnected” and the “Last Heartbeat” is from 4 months ago. How can this be possible? What’s controlling this? As I showed to you in previous screenshots in this forum, me account XXXXXXX@XXX.XX is set up in Studio, it’s the chosen one and there’s a green dot to the left of its name.

Orchestrator Folder Path is in “Autocomplete” mode, which means it doesn’t accept variables. You can recognize it from the “X” (or the dropdown symbol beside it):


To fix, click on the plus sign and then “Open in Advanced Editor”. Then you can provide the path as you have currently.


But @efelantti , I’ve checked during debugging and the activity is getting the proper value…

How have you verified it? I tested, and couldn’t get it working with a variable in the autocomplete mode - got the same error message as you in the screenshot. After opening Advanced Editor and setting the expression, it worked.

OMG @efelantti , you where right. My fault. It seems I was looking at the wrong value. Sorry.

Now it’s working, but by the way, what a pity… I’m inside a “For each asset row” activity. I have to assign the current iteration row element to a variable, then pass the variable to the “Get Credential” activity. What a lot of boilerplate.

Thank you!

1 Like

Good you got it solved.

You should be able to pass the expression as well when you are not in the “autocomplete” mode. However, I think it’s not bad to assign it to a variable first, as then it’s easier to troubleshoot in case of typos in the column name etc.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.