Calculate Client Hash Error

Greetings!

Again, having searched, I didn’t find this error.

I am on the step of updating the client’s work item with the hash. Several pieces don’t work.

I couldn’t get the select status drop down to work. Tried several ways to do it and nothing was consistent. Went to the walkthrough and tried to get it working. I can’t get the same result.

I’m trying to get the select combo box to work. I never get the id field as listed in the walkthru.

This is what I get:

html app=‘chrome.exe’ htmlwindowname=‘WI-Update’ title=‘ACME System 1 - Work Items’ />
webctrl tag=‘SELECT’ />

It never selects the id of newStatus as listed in the walkthru. I have tried it with UIExplorer. I have tried typing it into the selector. Nothing takes.

For the second thing, it won’t click OK on the confirmation pop up either. That selector is just

html app=‘chrome.exe’ />
Any thoughts on what I’m doing wrong?

Thanks!

Greetings.

I would try changing your tag to tag=‘A’

Dont forget that combo box is on another window (popup), so you will need to attach to it before manipulating it :wink:

Interesting on attaching to it. I am trying that but still get an error on the select combo box.

UpdateWorkItem.xaml (11.4 KB)

Thoughts?

Thanks!

I can assure that you have the right selector there, BUT, are you using chrome or firefox?? please check if you have the right browser type on your browser activities.

So, I did add default attach and it was set to IE. Switched that to Chrome. But still it doesn’t select the combo box, nor the Completed item in Combo box.

Does it not work in Chrome?

UpdateWorkItem.xaml (10.7 KB)

I mean you had your selector matching chrome, but you ran your code in firefox at some point…

Okay.

I fixed that, switched it all over to Chrome, and ran it again. It doesn’t work.

And the next two have been flaky at best.

Thanks!

UpdateWorkItem.xaml (11.4 KB)

In your activity:
Set Comments with Hash Code
You have as a selector:

<html app='chrome.exe' htmlwindowname='WI-Update' title='ACME System 1 - Work Items' idx='2' />
<webctrl tag='TEXTAREA' />

but since you are inside of an ‘attach browser’ you only need a partial selector like this:
<webctrl tag='TEXTAREA' />

and also it does not look good when your selector contains the idx attribute, try to avoid it.

Okay, that one works.

I agree about idx. I wouldn’t want to use it in a real environment. Trying to follow the walkthrough.

The Select for the combo button doesn’t work (Select Item ‘BUTTON’), nor does anything after that, if I comment those out and keep going.

Thoughts?

Thanks!

the Select Item is to be used in combo box not in a button, you will want to change that tag attibute from BUTTON to SELECT…

1 Like

change all to IE, i’ve redone this assignment before coz of issue with chrome

to be honest i dont use chrome with uipath unless i really have to…

Well, that really stopped me in my tracks. Not only do we support Chrome over IE, I don’t even have IE installed. I do have Edge installed but UIPath doesn’t recognize it.

I will keep seeing if I can get this to work on Chrome.

dont get me wrong, it will work with chrome as well, just saying uipath does the best recognition with ie, doesnt even need to install “extensions”…

Hi @jgoranso - One of my colleague also faced the same issue for Chrome Pop-up this issue persist because pop-up won’t appear on the DOM of webpage so the workaround for this is You can send Hotkey i.e Enter key to move forward.

Hope it helps.
Thanks!
Anmol

1 Like

@jgoranso - For the selector issue you can use anchor to achieve that or use wildcard or anchor base activity.

@bcorrea - I guess UiPath need ie extension to work in iexplorer. I can give you the example of this

  1. Try to run ie as a different user(Press ShiftKey +Right Click) on ie icon.
  2. Then enter id and password to the different user.
  3. then try to find the element using UiExplorer you won’t be able to find that and a pop up will appear.

Don’t get me wrong this is just my observation. I havetried other medium as well but it won’t work.

I dont see any info about the IE extension there:


:slight_smile:

Thanks for the updates!

@anmolk171, good thinking! I will try that!

Further, if anyone didn’t see it, as of some update, Community edition disabled C# projects. :frowning:

image

That is Studio2019.10.0-beta.155. I think a co-worker has higher. From my reading, maybe beta 0090 still works with C#? I don’t know for sure.

Thanks!