Bug since the 2019.10 update in Citrix records

Hello,
(english is not my native language)

Since the update :

  • My old projects in Citrix don’t run. They stop at the first “attach window” activity with that message : " Attach Window ‘CitrixRec Page’: unfindable method : ‘UiPath.UiWindow UiPath.IUiNode.GetTopLevelWindow()’.
  • The recorder in citrix mode doesn’t work : “Step was not recorded successfully” (but in desktop mode it is fine).

I tried to find something in the UIPath forum but the issues seems to be really different and are before the update.

Thank you for the time you took to read me (and hopefully answer).

Hi
welcome to uipath community

Fine are you getting this error for first time or you got that in yourr previous versions as
well

and

this should work fine
are you getting the citrix recording wizard to record the process,

Cheers @RPichon

It is the first time I get the error (and it is the first time I run my projects since the update, so I guess there is a link between those events).

I tried something new while answering you. I started a new project and it worked…
When I clic on the record button in the new project I’ve got 6 options : including “citrix native mode”.

When I clic on the record button in my old project I’ve got 4 options : basic, desktop, web, citrix (that “citrix” give me errors no matter what I do).

Do you know how could I make my old project work with recording everything ?

*without recording everything again

1 Like

this is strange buddy
Fine
Kindly uninstall the latest version and reinstall it and try once
Cheers @RPichon

Hi There,

I was having this error when starting to use 2019.10.
Attach Window ‘iexplore.exe’: Method not found: 'UiPath.UiWindow UiPath.IUiNode.GetTopLevelWindow()'

What solved the problem was updating the UiAutomation package to verson 2019.10.x
(also removed some unused packages, but I believe this was not part of the solution).

Regards

awesome
thanks for the info @Thiago