Bug report: Arguments between flows disappears

When passing arguments between the invoked flow and the main flow sometimes the variable from the main flow we entered inside the import arguments windows disappears.
Someone else notices this ?

1 Like


I too noticed the Scinario,
Thing is just after assigning/creating arguments do save the workflow, instructions if you click some other activity or adding another activity will wipe out your invoke workflow settings


This is extremely frustrating. I have now published a project after which it did not worked. I opened it and found that argument passed to the invoked flow is empty. And I am 100% sure that it was populated with a variable.
Can anyone from UiPath confirm this is a bug on their side and when can we get some info when will it be fixed ?

Thank you

Hi @Petar_Soce @megharajky

Could you tell us the version of Studio you are using?
Also, it would be very useful if you could write a short guide on how to reproduce the bug, preferably with some screenshots and a numbered list :slight_smile:


Version: Community 2018.2.4

Steps to reproduce:-

Drag activity: Invoke workflow file
Open edit arguments and pass the arguments also include the invoking workflow.

drag any other activity, say write line and write any text in that.

now open the edit arguments property from Invoke workflow activity the argument variable will disappear.

Unfortunately couldn’t able to reproduce as it happens very rarely, but this will not happen for sure if we save our sequence just after assigning arguments in Invoke workflow activity.


Unfortunately, I have trouble reproducing it on 2018.4. This might mean that the issue is already fixed in the newer version :slight_smile:

1 Like

Every time I import an argument I imidiately click “save” button which seems to resolve the problem. The steps are really just the same. I create an argument inside a flow. Then outside that flow in the main flow at the import arguments in the invoked flow i assign that argument to a variable and if I dont save sometimes ( not always) if I open import arguments again that argument becomes empty and I need to assign it again.
Using 3.2 version

This is an extremely old issue (and apparently still coming back…).

From how I handle this, is to not use ImportArguments once things are set - only Edit. Import seems to refresh the whole argument dictionary (from behaviour it looks like it creates a new one and matches what it can from the old one) and I’d guess that’s the reason while it’s sometimes not registering properly.
Saving immediately does seem to alleviate it a little, but still my “standard” way of updating arguments is Import->Set->Save->check via Edit->correct as needed->Save->check… and so on until it’s set as it should. This seems to be more prevalent the more arguments you have and also if you ctrl+k some of the variables.
Also always remember to press Cancel if you didn’t change anything, as pressing OK after ImportArguments seems to still replace the args dictionary.


I have noticed too, that after defining Arguments, saving the Project, closing UiPath (2019.1), when re-opening the project, all Arguments are gone… There is no argument.

Any idea what could it be?

Well I found what workd and I think thats how they imagined it. After declaring new arguments inside the workflow that you are invoking you have to save that workflow. Then from the outside workflow you have to first click on “import argument” ( then the arguments are imported) and after that click on “edit arguments” and then assigned them to what you like and save afterwards. Seems to work with no problem for me

It works for me too for most of workflows i have designed. Only in one, it just doesn’t save the arguments after i declare them.
The only i managed to add arguments to that project was to physically edit the xaml file and add manually there… Very strange… maybe there is a setting or something, but i haven’t found yet any logic.

Another similar situation, only on some workflows, the HTTP Request is raising an error after correctly it downloads the file. Randomly…

Thanks for reply

1 Like

This doesn’t seem to be an issue, follow below steps whenever you want to create arguments,

Suppose, you are invoking ProcessApplication from MainApplication

  1. Create Arguments in ProcessApplication
  2. In the Invoke WorkFlow File activity of MainApplication, click Import Arguments
  3. Now you would see your Argument written in ProcessApplication automatically populated in the Invoked Workflow Argument’s popup.
  4. Assign the value if needed.

Petar_Soce can you please explain in more detail.
I have the exact same issue that you described before, but i did not understand your last post / solution…Can you please explain once more

I had the same issue. I hope solution of this issue will help

The “import arguments” reads values from the invoked workflow.
After you’ve already set the values in the invoker(main) workflow, check the properties of the activity.
Open Input\Arguments
On this Arguments window you will see your values.

Cheers, Isti


Currently, I am having the same issue.
This seems to happen when the variable to be mapped is of type Dictionary, I have tried it with String it works fine.

This post helped me…