Browser upload file, can't type into file name

Hello, I’m trying to upload file but the robot can’t type into file name section. I tried both: SendWindowMessages and SimulateType and result is the same - the field stays empty. I don’t get any errors, just the field remains empty. When trying with default method everything works, but I can’t use that since I need for robot to work in background. Tried with IE and Chrome. I’d really appreciate any help. Thanks.

Hi Take selectors of filename where you want to type then use send hot key enter,it may work.


I guess, you might have missed providing file name in that step itself… It doesn’t record file name… we need to provide value in input variable… if you can upload your xaml i can verify that…

please search before posting :slight_smile: thank you.
try this.

Hi @Timber

I used to meet a problem same to you.
The way I used to solve that problem is:
Use “Attach to live element” to reselect that textbox. And It worked.
Please try my solution and let me know if it also works for you.

Best Regards,
Hoang Anh.


attach to live element is not a reliable solution.
It just take somewhat better selector than earlier.Might work for a while but not so long.
Always try to use UiExplorer to find out best and stable selector.

hi @ddpadil,

It’s very useful to know that.
Thank you so much.

Best Regards,
Hoang Anh.

I did search and I did find your link, but there were nothing that solves my problem

Yes, thank you, it worked perfectly

very glad to hear that.
If you have any problem, don’t hesitate to contact me.