Broswer extentions not working ie,chrome,mozilla

getting error while running the program in uipath
uipath extention in chrome/firefox/ie added but not working for me

Hi @rajesh

Welcome to the community!!

Did you install the extension through the studio?
What version of uipath are you using?
Does it show any error message?

Hi,
uistudio installed today only,
went to tools–>chrome and Mozilla extentions I saw both of them and enable extentions too.
uipath 2019.4.0(this is showing in my software ,is it version number?)

thanks a lot for quick reply

An ExceptionDetail, likely created by IncludeExceptionDetailInFaults=true, whose value is:
UiPath.Core.BrowserOperationException: Cannot communicate with the browser, please check the UiPath extension. ----> System.Runtime.InteropServices.COMException: Cannot communicate with the browser, please check the UiPath extension.
at UiPath.UiBrowserClass.Open(String bstrURL, UiBrowserFlags flag)

Yes it is the uipath studio version which is the latest

Can you try removing the extention, installing again and restarting the browser.

Let know whether it works

hi,
No use, I already searched and did the same and finally posted.
started learning and getting bored in this stage only…

@rajesh

If you work with IE browser then no need to install any extension. We have to install extension for chrome, Firefox and Microsoft Edge browser.

1 Like

I am tired of running my first program.
uninstalled and installed browser and uipath too…
ie
always getting error as "System.Runtime.InteropServices.COMException: Cannot find the UI element corresponding to this selector: "
chrome/mozilla:
System.Runtime.InteropServices.COMException: Cannot communicate with the browser, please check the UiPath extension.

verified in chrome : plugin installed and enabled.
vistudio-.chrome/mozilla clicked and checked the tick MARK for those browsers too

I am tired and hopefully someone will give perfect solution,

@loginerror any idea why this is happening?

Hi Lahiru/Lakshman,
if I changed the url it is working fine. my past url is C:\Users\rajesh\Downloads\selectors\rajeshPage.html and if i try with google url,it is working fine. I just followed a faculty and used the same pattern but based on the errors, i though something is wrong … but still getting a doubt how it worked for him and not mine.

Hi @rajesh

Are you accessing a offline website? You also mentioned that when you try the google url, it worked fine. Is it possible to share the google url so we also can have a look?

working fine with this–“https://www.google.com”
other url–“C:\Users\rajesh\Downloads\selectors\xxx.html” --got browser errors
i surprised why framework gave so much different error like "exention not supported’…like this.

my example;
i have 3 pages in my local with textboxes and hyperlinks and i tried to automate as my instructor taught me but not worked and throw me a high different errors and that is the problem…

still having a doubt how it worked with my faculty and not working for me in my local…(faculty also did the same as me)

@rajesh

I tried like this url and its working fine for me.

I am sorry my question might be wrong , I am trying example 2 HTML pages with text and interlink between 2 pages but that is not working and getting browser extension error but took a sample of Google URL and typed text and it worked fine . So previously got error is irrelevant if my issue and wasted so much of time and sharing that info to everyone.

opening the url is working for me but clicking the hyperlinks and enering the values in text boxes giving me errors(uipath is not installed like this ,this is the reason i wasted a lot of time)
could you please guide me how to get previous version of uipath studio . I observed that my faculty is using different version and i am in different version.

@rajesh

If you are using license along with Enterprise Edition of UIpath then you can request UIpath support team for previous version UIpath. Else you can copy it from your faculty system and install in your system.