Broken selectors after Chrome/Edge update to version 114.0.1823.37

The latest Chrome and Edge updates (114.0.1823.37) introduced a breaking change to the way support for Active Accessibility is enabled.

This causes automation processes to fail when trying to interact with the following browser screens:

  • Print popup
  • PDF viewer

Observed behavior

Following the browser update, it is no longer possible to identify web elements using Active Accessibility (AA) mode with UIAutomation activities.

Example of selector that no longer works because of this issue:

<wnd app='chrome.exe' title='RPA Resources*' />
<ctrl role='document' text='chrome://print/' />
<ctrl name='Print' role='push button' />

The problem occurs regardless of the UIAutomation package version or the Studio version.

Available workaround

Revert to Chrome / Edge version 113.

We are actively working on providing patches for all supported LTS versions of the UiPath.UIAutomation.Activities package, as soon as possible:

  • 23.4
  • 22.10
  • 22.4
  • 21.10
  • 20.10

We will update this post when these patches are released.

If reverting to the previous version of Chrome / Edge is not possible in your case, please contact our technical support team.

Update June 7, 2023

We have published the patches for versions 23.4 and 22.10. UiPath.UIAutomation.Activities packages with versions 23.4.7 and 22.10.7 are available in the official feed.

To resolve the issue, for the affected projects you need to update the UIAutomation project dependency to one of these package versions. Below is an example for updating UiPath.UIAutomation.Activities package to version 23.4.7.


Patches for the other LTS versions (22.4, 21.10, 20.10) will be released tomorrow and we will announce here once they are available. Thanks for your patience and we apologize for any disruption this may have caused.

Update June 8, 2023

UiPath.UIAutomation.Activities package versions 22.4.9 and 21.10.9 containing the fix have also been published and are available in the official feed.

The patch for version 20.10 will follow and we will announce here when it is released.

:mega: Latest update of the day

UiPath.UIAutomation.Activities version 20.10.14 has also been published. We now have all patches for supported LTS versions available on the official feed.

:bell: Update June 9, 2023

We have now published UiPathRemoteRuntime.msi v23.4.7. This version of UiPath Remote Runtime is compatible with all UiPath.UIAutomation.Activities packages containing the fix:

  • 23.4.7
  • 22.10.7
  • 22.4.9
  • 21.10.9
  • 20.10.14

If you are using Chrome/Edge for browser automation in a remote environment (Citrix, Windows Remote Desktop, VMware Horizon), and you updated your projects to use any of the above UiPath.UIAutomation.Activities package versions, you can download this UiPathRemoteRuntime.msi installer and upgrade the UiPath Remote Runtime on the remote server.

This is the last piece that will help you resolve the issues caused by the Chrome/Edge update.

We apologize for any inconvenience this may have caused and please let us know if any additional information is needed.


Any update regarding this ?

1 Like

Please let us all know whenever the fix for this issue becomes available.

Please update when this issue is fixed or I’m doomed

1 Like

If someone needs desperate fix and downgrading chrome is not possible. I accidentally found out really weird fix for this.

Fix: install and open Windows Accessibility insights.
If you open Windows Accessibility insights on the background UiPath seems to be able to find the selectors. I have no idea how and why this works. Maybe this will help the team solve the problem.

Disclaimer, I have only tried this on my local computer and one website.
The version of Accessibility Insights I am using is Production Release: v1.1.2213.01.


This worked as an emergency solution, thanks!
Everyone else be warned however, it can also interfere with other bot activities that normally work fine

Nice to know it works for others too. Remember to set “Highlight off” this should make it less intrusive.
This bug is really wierd.

1 Like

Any update on this issue?
A lot of processes stopped running because of this issue. we cannot revert to 113 because of our strict deployment system.

1 Like

I’ve downgraded to chrome v 113. Now even that’s not working…?

Has anyone examined whether or not this option needs to be enabled after the chromium update:

Hi Team,
Any update on the lower version of packages?

Also looking for an update please - Matt’s solution is saving a desperate situation but we are having to run bots via studio and this is not sustainable.


We didn’t see any reference to hyperlink pop-up menu. We have also issues with this pop-up menu:

As a workaround we can still use keyboard shortcuts… but we have to edit all impacted UiPath Projects.

So how does this work, does the dependency auto update when I open the project?

I dont seem to be able to update the dependency?


You would have to download the package version 21.10.9 & load it orchestrator or to your project nuget from the official UiPath feed



Thank you, I thought they somehow modified all the versions under 21.10

Problem is fixed if we use Modern (New) UiActivities.
Apparently no changes if we use Classic UiActivities.
Tested with latest 23.4 and 22.10

When will the update be provided for 20.10.9 V, we cannot upgrade the package as we are dependent on remote runtime version as well

I’ve tested 21.10 and 20.10 with Edge Settings windows.
21.10 works fine even with Classic and Modern activities.
20.10 seems partially working. Selector selection with AA works, but during execution Get Text, Click… is not working until I manually click somewhere on the browser window. I can do it when the execution is started from Studio but it’s not possible when it runs from Orchestrator unattended.
For now we stick to the solution mentioned in this post. It’s about Chrome, but I can confirm that it also works in Edge.

The additional information from this post is also important to make it work: