Broken selectors after Chrome/Edge update to version 114.0.1823.37

So how does this work, does the dependency auto update when I open the project?
image

I dont seem to be able to update the dependency?

Hi,

You would have to download the package version 21.10.9 & load it orchestrator or to your project nuget from the official UiPath feed

2 Likes

Hi,

Thank you, I thought they somehow modified all the versions under 21.10

Hi,
Problem is fixed if we use Modern (New) UiActivities.
Apparently no changes if we use Classic UiActivities.
Tested with latest 23.4 and 22.10

When will the update be provided for 20.10.9 V, we cannot upgrade the package as we are dependent on remote runtime version as well

I’ve tested 21.10 and 20.10 with Edge Settings windows.
21.10 works fine even with Classic and Modern activities.
20.10 seems partially working. Selector selection with AA works, but during execution Get Text, Click… is not working until I manually click somewhere on the browser window. I can do it when the execution is started from Studio but it’s not possible when it runs from Orchestrator unattended.
For now we stick to the solution mentioned in this post. It’s about Chrome, but I can confirm that it also works in Edge.

The additional information from this post is also important to make it work:

Unfortunately that’s not the way how fixes are provided. there won’t be a new 20.10.9 version, but the fix is included in the v20.10.13 package.

As 20.10.9 and 20.10.13 has a different UiPath package dependency. So to make remote runtime work with 20.10.13 UiAutomation package you have to update the Remote Runtime installation on the remote server by copying the necessary dependencies. Check this description:
https://docs.uipath.com/studio/standalone/2023.4/user-guide/about-uipath-remote-runtime#side-by-side-support

image

image

thanks for your response , well that will take a long time to update the remote runtime in server, but we have enterprise license, if we approach the UiPath support team , will they provide this update in 20.10.9 version for us

@Luiza_Surdu-Bob

I have checked 22.10.7 and 23.4.7 dependency for UiAutomation package. I checked webpage for print option with UiExplorer and selector is not visible for Print/Save button. I described the problem in post: Active Accessibility stopped working after Chrome update

there is the webpage where I can’t see available selectors.

My Chrome version: 114.0.5735.110

I can not reverse Chrome version.

Hi UiPath Team,

Can’t find a 20.10.14 in my official feed :frowning:

Is that only on my side? Would you please help with it?

Looking forward to hearing from you,

Thanks in advance & Best regards,
Nestor

@Luiza_Surdu-Bob

Sorry. My mistake. Version 22.10.7 is working. After changing method to AA in UiExplorer selector is visible in Studio (I can pick it) but then Validation for selector has error:

When I start robot in Studio it sees selector and robot is clicking “Print” button. Validation error appear also with classic click. There is no validation error with Modern Design Click.

I didn’t test it in unattended mode from Orchestrator.

@liviu.leordeanu Do you have any information on this? We couldn’t find the version 20.10.14 in the official feed.

This is not solution, but I can confirm that I have this version available:

I checked that in Windows-Legacy project (the same as in your screen)

Hi @Amrita.Hegde ,

Indeed, for old projects using the https://www.myget.org/F/workflow/ feed, UiPath.UIAutomation.Activities version 20.10.14 didn’t appear. It was available only on the new official feed: https://pkgs.dev.azure.com/uipath/Public.Feeds/_packaging/UiPath-Official/nuget/v3/index.json
Now it is published in the myget feed as well. Please try again.

Thanks,
Luiza

Hi @Yameso ,

There seems to be a problem when trying to indicate an element from Selection Window or from UI Explorer, only for the first time. But if you click once in that window and then indicate again the button, it will find it and show it as valid.
I’ve tested this workaround both with modern and classic Click activities and it works.
The problem only occurs for design time. At runtime, if you already have the good selector saved in the activity, the target will be found.
Can you please try if it works for you?

Thanks,
Luiza

Hi @Nestor_Levytskyy ,

UiPath.UIAutomation.Activities version 20.10.14 is now also available in the myget feed. You should be able to find it. Can you please check?

Thank you,
Luiza

1 Like

Hi @Luiza_Surdu-Bob,

Thanks for your help, I do confirm it’s present now in the feed :slight_smile:

Best regards,
Nestor

I think its working fine, the only thing I need to do is to change UiFramework to AA because it’s not accessible other way and UiExplorer can not detect it automatically. This is not issue for me :wink: Shortkey F4 is easy enough :slight_smile:

we have installed latest version of UiPath extension and UiPath Assistant in prod server and also tried with above mentioned steps like updating UiPath.UiAutomation.Activity package to latest 23.4.7 but still facing same error that ui element not found after upgradation chrome version to 114. . And same workflow is running fine in other server.

Please help to resolve this.

Hi @bhagyashri.kasture ,

If the same workflow is running fine in other machine with Chrome v114, it could be a different issue than the one related to the Chrome/Edge update.

Does the UI Element not found error occur for selectors using <ctrl /> tags (i.e using Active Accessibility - AA)? Only that type of selectors would be affected by the Chrome/Edge update.

For first troubleshooting steps, I recommend the following:

  1. As you don’t have UiPath Studio installed on that machine, but only the UiPath Assistant, try to re-install the extension with the SetupExtensions.exe tool (see https://docs.uipath.com/studio/standalone/2023.4/user-guide/about-the-setupextensions-tool)
  2. Check the troubleshooting steps described in this page: https://docs.uipath.com/studio/standalone/2023.4/user-guide/chrome-extension

Best regards,
Luiza