Bot types text into wrong fields every other time

Trying to automate timesheet entry into web browser. The bot reads my timesheet from an excel file and then types into a website after filtering by day.

I’m running into issues where it sometimes types into the correct columns but then other times when I run the bot it will type in the same field twice or skips a field or retypes the next item in the same field as the previous one…etc I’ve tried using an anchors to fixed fields above to see if this fixes the issue but it still happens. I am using a for each row activity and then about 5 get rows and type into activities
in a sequence. Below are dynamic selectors I am using. thanks for the help.

Selectors

Code /w Anchor ID

html title=‘My Timesheet’ /><webctrl tableCol=‘3’ tableRow=’"+Number.ToString+"tag=‘TR’ /><webctrl tag=‘INPUT’ /

Activity ID /w Anchor Activity ID

html title=‘My Timesheet’ /><webctrl tableCol=‘5’ tableRow=’"+Number.ToString+"tag=‘TR’ /><webctrl tag=‘INPUT’ /

Role /w Anchor Role

html title=‘My Timesheet’ /><webctrl tableCol=‘11’ tableRow=’"+Number.ToString+"tag=‘TR’ /><webctrl tag=‘INPUT’ /

Location /w Anchor

html title=‘My Timesheet’ /><webctrl tableCol=‘13’ tableRow=’"+Number.ToString+"tag=‘TR’ /><webctrl tag=‘INPUT’ /

Hours NO Anchor

html title=‘My Timesheet’ /><webctrl tableCol=‘23’ tableRow=’"+Number.ToString+"tag=‘TBODY’ /><webctrl tag=‘INPUT’ /

In Selector, single quote missing and It should be like this: tableRow=’ “+Number.ToString+” '

It always looks like an unreliable selector. Try checking if you can add maybe aaname, id, name on your selector.

1 Like

@tagmct I think selectors are changing dynamically please make it as stable.