Bot Stops Working when minimizing Remote Desktop

Hi guys,
I am facing a weird issue. I have published a bot which opens an excel, sends a hot key to it to refresh data and then use the refreshed data and stores it into two data tables. After this, it opens SLACK on the browser and types the values obtained from the data table as a chat using the “type into” feature.

The whole process works perfectly whenever I am watching the RDP. However, if I switch off the RDP or minimise it, the process fails with a time out exception.

I tried Invoke workflow interactive, set resolutions into it, activated options like “Login to Console”, but none of the methods are working. Is it a limitation of the community edition or am I doing something wrong?

Please suggest any resolution. Thanks!


Please go through below link:

UiPath does not work in Cloud

Hi @lakshman
I have done this and still I am getting Timeout exception.
Screenshot of Registry editor

Error in the logs
The second entry says that the timeout was reached for HOTKEY, since my system was diconnected.

Settings of my Orchestrator Robot

Settings of my UI Studio Invoke Workflow Interactive

I have tried everything I could find through the forums but nothing has worked. It is something which is a limitation of the Community Edition or UIPath in general? Or am I doing something wrong?

Hi @abchakraborty,

Community edition doesn’t have the feature of bot working when minimized remote desktop ,but licensed versions have that feature.

But still you can go through these posts,

Input to Browser fails when remote desktop is not connected
Remote Desktop
Uipath can’t perform clicks on a minimized RDP session
RDP Session Running UiPath Fails On PC Lock
UI Path scripts are failing when RDP is disconnected

Thanks a lot @anil5. Can you please help me out with the process of knowing the pricing for the licensed edition and the required specifications. This will help me pitch it better to my managers at my firm.

@abchakraborty, uipath team will be helping you on this.

@loginerror, can you help knowing him about the license structure.

Hi @abchakraborty

Please contact our Sales representatives to receive most up-to-date information tailored to your needs:

Dear @anil5 @loginerror and UiPath team,

This “RemoteDesktop_SuppressWhenMinimized” also applies if the session of the ACTUAL machine is locked too? In my case, it got locked after a few minutes due IT policy after inactivity of ACTUAL machine (robots are executed in a VM via RDP but robots fails when ACTUAL Machine got locked due this inactivity, otherwise they run 100% accurate)

It is very important and mandatory for us if this scenario will work in order to buy the license, please clarify, as soon as possible.

License and computers architecture:

  1. UiPath Studio Development License (My PC)
  2. Laptop with Windows 10 used to connect Via RDP to the Windows Server where robots are executed
  3. UiPath Attended Robot License (Windows Server Virtual Machine)
  4. No orchestrator

Please refer to this link:

Waiting for your reply.

Thank you in advance for your assitance.

Hi @Masta,

Yes the robots fails when the system locks.

As you told you will not be using orchestrator.

Can your IT guy perform these actions on the VDI, that the system never locks

@loginerror, cam you through some more light on this.

Dear @anil5 and @loginerror

Just to be sure, the main idea here is use a Laptop in order to connect to Windows Server VM via Terminal Server (RDP).

The issue comes when the robots are executed in the remote server. In this case, the host machine (the laptop) due inactivity it gets blocked, and all robot executions located in the Terminal Server, fails.

In the refered post “RDP Session Running UiPath Fails On PC Lock” in my last post @nathlord93 says that this works for him, but he dont say if he is running Community Edition or license model or if he is using an orchestrator.

Maybe in the licensed version, that includes robot Windows services, this is not a problem at all. In my case they are attended robots: the bots needs user imputs like file paths and Excel files to do their jobs.

@anil5 on the other hand, leaving the machine unblocked may cause a security problem, so in this case I am asking for a safer solution :wink:

I modified the register but the result is the same…fails! but I am using the Community Edition for now.

I dont know if I need and orchestrator, but being attended robots, I am not quite sure if this configuration apply to this escenario. @ovi

Thank you all,
Waiting for your Reply

Hi @Masta

It should be possible to run an unattended process and then lock the screen and it should continue working. This is not possible with the Community Edition though.

Part of the difference between CE and EE is that the Robot process is installed per user for CE and per machine for EE.


Hi @abchakraborty, i have the licensed version of the bot and updated the same on the bot. Still it is not working. Is there any other reason for this issue ?

I am also facing same issue

which bot you are using, assisted or unassisted ?

assisted and unassisted

assisted bot won’t be able to function on minimized remote desktop.

To enable the bot to create its own session please set Login to Console No and then pass the resolution to it.
Also It will disconnect your RDP as soon as the Bot starts.
Also please try to remove the selector from Send Hot Key and try to keep it in a container of the application like Attach Browser ,etc.

1 Like

Sir one more thing As mention in attachment my application running in chrome while in between if I open another think eg if I open notepad as mention in attachment then Send hot key with TAB not work and when I minimized notepad then it start working file…

If we change the active application manually then it will tend to fail. Ensure that the activities are surrounded in container and we have the application active.

sorry did not understand…!