Bot slowness issue : Write Cell

Hello Everyone,

My process runs super slow. Initially it used to finish in around 5 mins but lately it takes around 14 mins on an average to complete one transaction sometimes even more. I debugged and found issue in my write cell activities which I use to update my status file at various stages of my process. Write range will not serve my purpose. Anyway to deal with the issue?. Thought of creating a datatable and updating it at various stages but gonna be a huge change.

Pls advise some way to address the issue.

Thanks in advance. @Palaniyappan @badita @Lahiru.Fernando

Hello @vkshambhu

Sorry for my late reply.
So, based on your analysis, as I understand the delay is occured by the write cell?
May I know how you have configured your write cell?
I mean, what is the method you use to identify which row, and while column to update at different stages of the process?
Is it only the write cell that is causing the problem or any other activities, loops involved?

How many rows in Excel file? Too many maybe?

@Lahiru.Fernando @JDK Thank you for responding back. I am updating a row with around 10 columns for every transaction. Attached the write cell I used. Btw I have resolved the issue by replacing write cells with datable and updating excel at the end of my transaction. Nevertheless write cell does cause lot of slowness. While debugging I did not find any issues with other activities.

2 Likes

Man, maybe Im here a bit late haha.

You have to untick the option to save the book on the Excel Application Scope, it saves the book after any movement you do, so you write a cell and have to wait until change is saved to write another, and it will take so long if the book have a big amount of data. So, you untick that option and manually use the save option at the end of the scope, that worked for me, I came searching for the same problem.