Bot not run uipath assistant only on studio Could not load file or assembly 'UiPath.IntelligentOCR, Version=

Bot not run UiPath assistant only on studio
Could not load file or assembly ‘UiPath.IntelligentOCR, Version=, Culture=neutral, PublicKeyToken=null’. El sistema no puede encontrar el archivo especificado.

at UiPath.IntelligentOCR.Activities.Digitization.DigitizeDocument…ctor()
at BudExchangeDispatcher.DocumentUnderstanding.DU_Unattended.Main.GetImplementation()
at System.Activities.Activity.OnInternalCacheMetadata(Boolean createEmptyBindings)
at System.Activities.Activity.InternalCacheMetadata(Boolean createEmptyBindings, IList1& validationErrors) at System.Activities.ActivityUtilities.ProcessActivity(ChildActivity childActivity, ChildActivity& nextActivity, Stack1& activitiesRemaining, ActivityCallStack parentChain, IList1& validationErrors, ProcessActivityTreeOptions options, ProcessActivityCallback callback) at System.Activities.ActivityUtilities.ProcessActivityTreeCore(ChildActivity currentActivity, ActivityCallStack parentChain, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList1& validationErrors)
at System.Activities.ActivityUtilities.CacheRootMetadata(Activity activity, LocationReferenceEnvironment hostEnvironment, ProcessActivityTreeOptions options, ProcessActivityCallback callback, IList`1& validationErrors)
at System.Activities.Hosting.WorkflowInstance.ValidateWorkflow(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.Hosting.WorkflowInstance.RegisterExtensionManager(WorkflowInstanceExtensionManager extensionManager)
at System.Activities.WorkflowApplication.EnsureInitialized()
at System.Activities.WorkflowApplication.Enqueue(InstanceOperation operation, Boolean push)
at System.Activities.WorkflowApplication.SimpleOperationAsyncResult.Run(TimeSpan timeout)
at System.Activities.WorkflowApplication.BeginRun(AsyncCallback callback, Object state)
at UiPath.Executor.InProcessRunner.<>c__DisplayClass6_0.g__StartWorkflow|1()
at UiPath.Executor.InProcessRunner.BeginExecute(AsyncCallback callback, Object state)
at UiPath.Core.Activities.ExecutorInvokeActivity.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)
at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)


Could you copy the Intelligent OCR package to packages folder on the machine where you are trying to run it from.
Seems like a dependency issue, If it still persists delete the whole package for Intelligent OCR and download it again from Manage Packages.


It could not download the dependency compeltely

Please go to this location c:\users\<username>\.nuget\packages

Delete the ocr related pckages and let the bot re downlaod…better delete the project related folder as well…so it is freshly downlaoded…if even then it is not fixed then as workaround copy the same folders from your dev machine to the machien where youa re executing and the location would be same as above


Hi @Luis_Velez,

What Studio version do you use?


2023.4.2 version , seems like a bug

the packages is already there, i delete, redownload and updates, i don´t wanna downgrades only works if i downgrade to version 6.5 of that activities but that in not an option

not run on unattended mode

please any solution?


Try adding this in the orchestrator feed and check if the activity continues


the bot run on studio only

Hi @Luis_Velez,

It was a bug and it was fixed in 23.4.2. In order to have the process running, you need to republish it. Can you do this and let us know if it works or not?


no was solved , i am using that version, i delete and publish again the error persist, help i am in production running via studio

Same error here but with another library: Could not load file or assembly ‘UiPath.SmartData.Telemetry, Version=, Culture=neutral, PublicKeyToken=null’. El sistema no puede encontrar el archivo especificado. at Source: Throw

can you tried downgrade the package

The problem is quite straightforward - the unattended robot cannot find the package UiPath.IntelligentOCR, Version= . This is usually due to the robot being restricted to only accessing its Orchestrator feed and the package not existing there. The simplest solution is to add the package to the nuget library of the Orchestrator that controls the robot.

Try to not add the DocumentUnderstanding package to your project or downgrade your IntelligentOCR and DU-related activities.

We would like to inform you that UiPath.DocumentUnderstanding.Activities is not designed to be used in conjunction with Intelligent OCR. These two packages serve different purposes. UiPath.DocumentUnderstanding.Activities provides simplified activities for Studio Web, while Intelligent OCR offers similar activities but with more advanced and intricate functionalities for Studio Desktop.

Please remove UiPath.DocumentUnderstanding.Activities from the package dependencies and let us know the results.

1 Like

" The simplest solution is to add the package to the nuget library of the Orchestrator that controls the robot." this is not a solution. the packages is available on tenant feed as is showed above, downgrade the packages is not a solution viable because means a rework of all activities

I have the same problem. The robot downloads the package from Orchestrator on local machine but then generates error.
What is your recommendation?