Bot is not running from orchestrator if Remote desktop is closed

Hi,

Kindly help me with this issue.

i have created a bot in Remote desktop and published to the orchestrator. I scheduled the bot to run at specific time. If i keep the remote desktop connection as open means, the bot is working fine …

If i close Remote desktop connection and try means , all UiElement based activities[click,type into] are not working .

i tried Login to console as no and also specified width and height but no luck.

1 Like

@shnega

Check the robot license is unattended

If not try with unattended license so it has capability to unlock the RDP and perform the actions

Hope this may help you

Thanks

Hi,
robot license is unattended only

Hello @shnega ,

There are few things that you must configure, to be sure that Unnatended robot is working.

  1. Update the Robot settings for resolution
    Robot Settings

  2. Use for type into/click that support background execution
    Input Methods

  3. Also check this article:
    Executing Tasks in a Minimized RDP Window

I hope it helps.

Vasile.

1 Like

hi @wasea
I tried robot settings and Input methods , but no luck

Do you get any exception screenshot? Otherwise I would suggest you to implement that, it is useful for identifying these types of issues, f.e resolution as @wasea mentioned.

Hi @Obsev
I have used take screenshot activity to take screenshot if any error occurs in catch block. It is capturing the screenshots only i run the bot by keeping RDP open.
If i close RDP and run from orchestrator means , it is throwing exception as Imageoperationexception

Hi @shnega , please check this article: According to Deployment

Hi @dimibot
I tried your idea too but no luck .Now click ,type into activities are working but click image, image exist are not working .
Kindly help me with this

@shnega

Click Image, Image Exists works are the Image activities, if the resolution is not accurate then it fails

Check the accuracy in the properties also you can remap the element from the existing environment

Hope this may help you

Thanks

Hi @Srini84
Click image and image exists are working when i keep my RDP open…
if i close RDP and try, it is not working

Hello @shnega,

Did you solved your issue?
If yes, what was the solution?

Vasile.

Hi @wasea
issue solved .
i reduced accuracy of image and image exists activity to 0.6 . then it worked.