Bot fails due to A foreground process is already running

@arijit1213

Then it should go to pending state only.

Do one thing create one small process with Message box activity and publish it into Orchestrator. And then check it whether it is giving same error or not.

1 Like

@lakshman
ok

1 Like

hi @lakshman
i try this.
i started the process with message box then i run another process.
And result is same that another process fails.
image

hi @lakshman
what can i do to overcome this issue?

@loginerror @Pablito @Lahiru.Fernando

Do you have any idea why it’s giving this kind of error ?

1 Like

Hi @arijit1213 @lakshman

I tried this again in my Orchestrator, and it is giving the expected (one is running and one is pending) scenario

It should not throw the error…
My robot type is set to Unattended and I executed the two processes from the Processes screen in the Orchestrator.

Can you show us how you configured your robot? just to get an idea…

1 Like

Hi @Lahiru.Fernando
i try it once again. but i am getting the same error.

That’s weird…

Can you try this. Can you disconnect your robot from the orchestrator, and set it up again, and try… :thinking:

hi @Lahiru.Fernando
i try it bot the same error occurs again

Is the machine maybe configured with multiple runtimes?

hi @loginerror
no. only one machine is configured.

Hi @Lahiru.Fernando
can you please try to run the two processes through Assistant. And check it what the state shows.

1 Like

HI @arijit1213

Nice spotting… You are correct…

It gives the error when starting through the Assistant… :slight_smile:
image

1 Like

@Lahiru.Fernando @arijit1213

Yes it will give error when we will try to run it from Uipath Assistant as we can run one foreground process at a time but not getting why it is throwing this error when we run it from Orchestrator.

Yeah… I actually tried it again… I basically have so many processes like that… that start at once, and execute one after the other… :thinking: its weird…

1 Like

Can you try this once…
Delete your machine and the robot in the Orchestrator, and disconnect the local bot from the Orchestrator…

Configure and create the machine and the robot again in Orchestrator, and connect it again and see whether it works

1 Like

@Lahiru.Fernando

I tried it from my end too and it’s working fine in Orchestrator but don’t know what went wrong with him @arijit1213.

As @Lahiru.Fernando said, delete it and reconfigure again.

1 Like

HI @Lahiru.Fernando @lakshman @loginerror
I solve this by changing the domain\user name. i go to cmd and ran the command whoami.
After that i copy the data from cmd and past it in domain\user name. After that bot goes to pending state.

2 Likes

Great @arijit1213

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.