Best practice for deploying robots to a virtual machine?

Hi folks, I’m hoping I can find some advice for the issues we’ve experienced deploying our attended robots to a shared virtual machine that IT has provided our group.

So far my deployment process has been to publish the RPA project to a specific folder, drop the RPA Nuget package in Orchestrator and then deploy the package to the VM.

This has worked for us; we have had decent success with our RPAs for nearly 2-years now.

The VM is currently shared by 3-users, all whom I setup with remote login privs (IT may have setup the 2nd user w/Admin privs like myself - the 3rd user, probably not, being new - I’ll have to check.)

There are three outstanding issues we’ve encountered - one, about 2-months ago while running a newly developed RPA.

User #2 was running an RPA I developed, and she discovered a minor bug during her testing.

I repaired the RPA, published, then updated the RPA nuget package in Orchestrator, updated the RPA on the VM, ran, and tested the update; the reported bug was shown to be fixed.

The problem occurred when the 2nd user logged into the VM, and when she ran the updated RPA, the RPA would get to a certain point and just STOP??

When I logged into the VM, and ran the same v1.59 RPA version, the RPA would succeed wo/any issues for me - madness!??

Fortunately when I gave her the Studio project, she was able to successfully run the RPA on her dev laptop in Studio and got the job done in time.

As a bit of history - when we first received the virtual machine, NONE of my published RPAs would run; I’d download them from Assistant, run them and they never even got to the initial “choice” dialog that should have opened.

Long story short, I discovered I had to manually copy a bunch of MISSING nuget packages from my dev pc, up to the VM, then the RPAs worked fine!

Due to that first problem, early on, I suspected it was a similar issue for the 2nd user and I confirmed it today by looking in the Nuget folder for her account and compared it to my Nuget folder - files were either missing or different!

I would have thought that Orchestrator would upload / update required packages for a published RPA?? And I also assumed the nugets would all be in a shared / common folder, instead of one for every individual user??

Am I perhaps doing something wrong with my publish process?

Is there any advice you can provide as to how to avoid these issues with missing / different packages between users?

I’m thinking I may have to create a singular login account on the virtual machine, which everyone shares (multiple people can’t use the VM at the same time anyway.)

Again, any help / pointers are appreciate; perhaps I’m doing something wrong in the way I’m publishing the RPAs; managing multiple nuget folders for all the various users on the VM is a horrifying thought, IMO.

My 3rd user, when he publishes his robots to the VM, he doesn’t even see his RPAs listed in the Assistant panel! I have yet to tackle that issue with him!

Any advice, or suggestions are really appreciated - thanks!

Hello @WillBellJr!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly
Forum_Staff