...because it is being used by another process

Hello guys,

I have this problem from time to time, not only for word, but also for excel.
I used Kill Process and put a delay. However, the error persists.
Do you have any explanation or solution other than what I tried?

Thank you!

image

Hi @anamariavioleta.dinca

Check the below video,

Hope it helps!!

1 Like

Have you tried using the modern activities?
They handle this waaaay better.

Also consider opening read only if you don’t need to edit them?

1 Like

@anamariavioleta.dinca

1 Like

Hi @anamariavioleta.dinca

Where the files are storage? Do you are using some sync tool like onedrive?

I need to edit the file and I tried also with the modern activities…

yes, them are on onedrive

@anamariavioleta.dinca

probably the issue is onedrive trying to sync the file. You can try copy the file to a non sync folder, edit it then save again the file into one drive folder (overriding the old one) or use the Office 365 Activities to deal with 365 files directly

1 Like

Ah, well thats your problem.
The OneDrive application is absolutely dire, especially with RPA.
I always immediately turn it off as soon as I get a new work laptop. In my experience with RPA OneDrive will consistently just ruin your work by not saving correctly, sync issues, you name it.

If you want to work with a file on OneDrive I strongly suggest switching to the Integration service activities and working with it directly on OneDrive.

just to complemeting on this

Sometimes your user profile are forced to sync by organization policies. In that case, it is a really bad idea have your Studio projects inside a onedrive folder while you are working on it. It causes a lot of sync issues as mentioned by @Jon_Smith

:nauseated_face: :face_vomiting:

Yuuuup, another reason to avoid OneDrive like the plague, it will ruin your Studio projects. If I ever see someone with their in OneDrive I immediately tell them to move it somewhere safe.

Its scary to see some people use OneDrive for their backups instead of source control.

Only the input and output files are on OneDrive

Which are the Integration service activities?

@anamariavioleta.dinca

Instead of using directly from one drive…try to copy it to any other folder which is not syncing to one drive and then perform operations and then move back the file

Cheers

1 Like

So what it works for me in this moment is to put a bigger delay because maybe it takes a longer time to access the file. Thanks!

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.