BC30561: 'Action' is ambiguous, imported from the namespaces or types

Hello everyone,

I have researched this error extensively through the forms but have not found a solution that has worked yet. Within my automation, I am attempting to do the following in Outlook:

  1. Use Application: Uses Google Chrome to pull the [provider_name] variable (which will be used as the folder name)
  2. For Each Email: Searches for each email based on the filter provided
    3a. Try Catch: If email exists, move email to [provider_name] folder;
    3b. If not, create [provider_name] folder and move email into it

However, when I attempt to step 3a, error BC30561 pops up. I tried playing with the package versions to no avail and I attempted using a text editor to remove the <x:String>Microsoft.Office.Interop.Outlook</x:String> lines, but that just results in error:

*The type or namespace name ‘_Folders’ does not exist in the namespace ‘Microsoft.Office.Interop.Outlook’ (are you missing an assembly reference?)

Any ideas on how I can get this running?

What is generating the error? When are you getting the error?

Since your using Outlook. Is Outlook Application installed in the system where rpa automation solution is being created?

I get the error once the automation checks for errors prior to running. It specifically appears in a variable (provider_name) I create and a Multiple Assign set up as such within the Outlook Scope:

  • oFolder (Data Type: Object) = oApp.Session.DefaultStore.GetRootFolder().Folders

  • newFolder (Date Type: Data Type: Microsoft.Outlook.Interlop.Outlook._Folders) = oFolder.Add(provider_name,Type.Missing)

*Not in Multiple Assign but oApp’s Data Type: Microsoft.Outlook.Interlop.Outlook._Application

I would provide the files/screenshot but unfortunately, this is a new account.

Yes, UiPath recognizes the app.

Hi @kpaul1

Check this thread,It might help you

Hope it helps!!

Didn’t work for me, unfortunately.

Hi @kpaul1 ,

Is it possible for you to provide a Screenshot on where the error actually happens ? Also, could you provide the Dependencies used and its versions ?

We could try replicating the same and check out from our end the error if occurs.