Background problem

I transferred my automation to a remote desktop and set it to run every hour but it gives an error when downloading a file if I don’t have it on my pc screen, how do I solve this error because if I have my pc on his own screen and minimize the “remote pc” it doesn’t work


If you want to execute on minimized



  1. Identify the element of the pop-up window: Use UiExplorer or the “Indicate on Screen” feature to identify the pop-up window element.
  2. Use the “Element Exists” activity: Add an “Element Exists” activity and indicate the pop-up element to check if the pop-up exists.
  3. Add a decision (If) activity: Use the output of the “Element Exists” or “Check app state” activity as a condition in a “Decision” (If) activity.
  4. If the pop-up exists: Inside the “If” activity, use the “Click” or “Keyboard shortcuts” activity to click the appropriate button to confirm the download or handle the pop-up based on its behavior. For example, here the pop-up has “continue download” option, so use the “Click” activity or “Keyboard shortcuts” to click the “continue download” button.
  5. If the pop-up does not exist (optional): If the “Element Exists” activity returns false, you can add optional steps to handle situations where the pop-up does not appear.
  6. Continue with the file download: After handling the pop-up (or not), proceed with the file download process.

Hope it helps!!

You can’t run that way, with it minimized or locked, because then there’s no UI for UiPath to interact with. Why are you running it this way instead of doing it as an unattended automation through Orchestrator? Your other option would be to run it PiP.

Hi @william_emanoel

You are running your bot in attended mode. You have developed with UI elements in your project. When the project runs the UI elements has to appear on screen then only bot will detect and run the program successfully. Bot search for the UI element if the UI elements is not detected by bot it will throw an error like “UI element not found”.
Your machine screen hasn’t be locked and shutdown. When the bots runs the machine has to be in on position.

If your requirement when the screen is locked the bot has to be run then use the unattended mode. In unattended mode it will run at the background.

Hope it helps!!

This isn’t quite accurate. When running unattended it establishes its own RDP session and therefore it’s not running in the background. Running background automations is a different thing.

I did what it says on this page but it still gives the same error as the image

(Autonomous automation through Orchestrator? Your other option would be to run it PiP.) How do you make this automation of mine turn into an autonomous automation (but I need the automation to continue having the clicks and writing in the login areas)

It’s called an unattended automation and it’s a standard part of RPA.


The above settings work for attended automation…I hope your is an attended automation and robot is in user mode


Thank you very much, I fixed the robo account but it does not appear when I go to associate it to do my automation

would it be in “machine” to associate the robo account with automation or would it be somewhere else?