Back Office Robot Not running

When i run my process in VM machine through UI Path orchestrator the script runs only when the VM Connected or else it was not working…

Error message:

  • Info: “Execution error : System.ComponentModel.Win32Exception: Access is denied\r\n at System.Activities.Statements.MethodExecutor.InvokeAndUnwrapExceptions(Func`3 func, Object targetInstance, Object actualParameters)\r\n at System.Activities.Statements.MethodResolver.SyncMethodExecutor.BeginMakeMethodCall(AsyncCodeActivityContext context, Object target, AsyncCallback callback, Object state)\r\n at System.Activities.Statements.MethodExecutor.BeginExecuteMethod(AsyncCodeActivityContext context, AsyncCallback callback, Object state)\r\n at System.Activities.Statements.InvokeMethod.BeginExecute(AsyncCodeActivityContext context, AsyncCallback callback, Object state)\r\n at System.Activities.AsyncCodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)\r\n at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)\r\n at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)”

Please help on this guys its very urgent

Hi,

I have the same issue currently. Did you get any answer on that?

Hi @cfrelet

It might be related to your anti-virus software that is blocking access of our software to necessary folders on the C:\ drive. Please disable it temporarily to see if the issue persists.

If it does, I would suggest contacting our Technical Support for assistance.

@cfrelet @loginerror

Hi Guys,

In UiPath Orchestrator there is an option to run the Robot in Back office when we set up the Robot i believe it is not available in Community edition.
Please correct me if am wrong.

It is correct. Studio CE and Orchestrator CE only provide you with Development robot licences. You need an Unattended Robot licence to run robot on a locked screen or via RDP connection.

Hi,

I solved one of my robot issue here. I did the changes as I did in prex:

  1. https://robot.uipath.com/docs/installing-the-robot

  2. https://robot.uipath.com/docs/executing-tasks-in-a-minimized-rdp-window

  3. Install Uipath Studio 2016.2.66.55.19951

  4. I made sure I have no session open at all and run the job in orchestrator.

It solved my issue. I can now run robot with the resolution displayed in uipath.setting

But then I tried to do the same with my production machine. I did step 1 and 2. But I can’t do step 3 because it’s a production machine with Uipath Platform version 17.1.6435.21855. Uipath Studio will not be installed.

When I do step 4 i get the following message:

  • Process : EquityMC_ExcelVersion
  • Environment : HKEQ
  • Robot : DKHKGVMPFE50_EqyMC
  • Info : "Executor start process failed, reason System.Runtime.InteropServices.COMException (0x80070520): A specified logon session does not exist. It may already have been terminated. (Exception from HRESULT: 0x80070520)\r\n at UiPath.UiSystemClass.OpenInteractiveWindowsSession(String bstrUser, String bstrPassword, UiOpenSessionFlags nFlags, String bstrApplication, String bstrAppArguments, Int32 nDelayMs, Int32 userToken, UiGenericOptions options)\r\n at UiPath.Core.Setup.OpenInteractiveWindowsSession(String username, String password, OpenSessionFlags flags, String application, String arguments, Int32 userToken, Int32 preferredWidth, Int32 preferredHeight, Int32 preferredDepth)\r\n at UiPath.Service.Impl.Executor.StartProcessInSession(Guid executorInstanceId, String username, String password, OpenSessionInfo sessionInfo, IntPtr userToken)\r\n at UiPath.Service.Impl.Executor.<>c__DisplayClass13_0.<<Start>b__0>d.MoveNext()"
  • Start Time : 2018/11/23 10:17:02
  • End Time : 2018/11/23 10:17:34

ANy idea?

ok I solved that one also by reinstalling properlt version more compatible between orchestrator and Uipath platform. I reinstall everything with the proper prerequisite with UiPath Platform v2017.1.6682.

And it worked fine.

I seriously believe the install is very sensitive.

Whether it will run when the RDP connection system on a locked screen? @loginerror

Hi @arunshiva

Yes, unattended robots are capable of establishing an RDP connection by schedule of Orchestrator.

@loginerror
Sorry to ask again
So it will work even when the RDP Machine in a locked screen?my understating is correct?
How it will connect the Chrome Extension and all?
If my understanding is wrong please correct me.

Hi @arunshiva

Sorry for very late answer :slight_smile:
The answer is yes, Orchestrator can connected to a machine as long as this machine is running and connected to Orchestrator (but can be locked).