Azure Nuget Artifact not visible in UiPath package manager

If you are trying to get Orchestrator to automatically pull from an Azure Packages Nuget feed I think I can help…

First setup secondary credentials for your Azure account.

Second, in Orchestrator configure the deployment settings to use the V2 URL of the Nuget feed - NOT v3. Such as:

https://pkgs.dev.azure.com/orgname/_packaging/feedname/nuget/v2

Third, enter your secondary credentials.

Hope that helps.

2 Likes

Hi!

What do you mean by “secondary credentials”?

Sorry the correct term is Alternate Credentials.

https://dev.azure.com/orgname/_usersSettings/altcreds

1 Like

Instead of the alternate credentials, it would be great if we could use an API token from Azure DevOps, as explained here.

The problem with this is that there is an arbitrary limitation on the password length for the package authentication credentials in Orchestrator, and the token generated in Azure DevOps won’t fit.

@loginerror Is there any chance this upper limit can be increased?

Hi @nkuik

I believe this might not be possible, but feel free to reach to our technical support for more certain answer.

From my research, it would seem that the length might be related to the data type of the data table that stores the information related to the field.

Hey @cheapshot2000, @loginerror, all,

I am trying to connect Orchestrator to an Azure DevOps > Azure Artifacts instance which will host our packages. I have set things up like you have indicated - i.e. Alternate credentials, and using the v2 feed URL. I keep getting the same error though when publishing a new package to Orchestrator via Studio connected with Orchestrator - “Error: System.ApplicationException: Publish of workflow project to Orchestrator failed. Cannot connect to packages feed, the Deployment Settings may be invalid. —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Cannot connect to packages feed, the Deployment Settings may be invalid.

Any idea what I could be missing? Seems like I have followed what has worked for others…I am sure I am missing a devil that is in some detail!

Got any screenshots you can share?

Will post them tomorrow mate.

@cheapshot2000 here you go mate. Will appreciate your thoughts.

Orchestrator configuration (redacted our instance specific bits)

Azure DevOps configuration

And here’s what an Orchestrator connected Studio tells me when I try to publish to Orchestrator. This worked fine when we had Internal Deployment (deploying to the file system).
image

Full stacktace (probably not relevant but still…)
Error: System.ApplicationException: Publish of workflow project to Orchestrator failed. Cannot connect to packages feed, the Deployment Settings may be invalid. —> System.ServiceModel.FaultException`1[System.ServiceModel.ExceptionDetail]: Cannot connect to packages feed, the Deployment Settings may be invalid.

*Server stack trace: *

  • at System.ServiceModel.Channels.ServiceChannel.HandleReply(ProxyOperationRuntime operation, ProxyRpc& rpc)*
  • at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object ins, Object outs, TimeSpan timeout)*
  • at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)*
  • at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)*

*Exception rethrown at [0]: *

  • at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)*
  • at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)*
  • at UiPath.Models.IUiPathRemoteDuplexContract.PublishPackage(String feedUrl, String packFilePath, Int32 timeoutSeconds)*
  • at UiPath.Models.UiPathDuplexProxy.PublishPackage(String feedUrl, String packagePath, Int32 timeoutSeconds)*
  • at UiPath.Studio.Plugin.Workflow.Project.BaseWorkflowProjectFactory.PublishToOrchestrator(String feedUrl, Int32 timeout, String packFilePath)*
  • — End of inner exception stack trace —*
  • at UiPath.Studio.Plugin.Workflow.Project.BaseWorkflowProjectFactory.PublishToOrchestrator(String feedUrl, Int32 timeout, String packFilePath)*
  • at UiPath.Studio.Plugin.Workflow.Project.BaseWorkflowProjectFactory.<>c__DisplayClass41_0.b__0()*
  • at System.Threading.Tasks.Task.InnerInvoke()*
  • at System.Threading.Tasks.Task.Execute()*
    — End of stack trace from previous location where exception was thrown —
  • at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)*
  • at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)*
  • at UiPath.Studio.Plugin.Workflow.Project.BaseWorkflowProjectFactory.d__41.MoveNext()*
    — End of stack trace from previous location where exception was thrown —
  • at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)*
  • at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)*
  • at UiPath.Studio.Plugin.Workflow.Project.BaseWorkflowProjectFactory.d__38.MoveNext(), HResult -2146232832*

So we have been able to test from a colleague’s machine who’s got a local deployment of Orchestrator, and reproduce this. The event viewer shows this. It looks like an integration issue of how Orchestrator is using Nuget. We are on 2018.4.3. Has someone else seen this and is there any workarounds? We tried populating the ApiKey in Web.config as well as the textbox next to the unselected radio button to “AzureDevOps” and still got the same error so that is definitely not picked up…

Also thought I should mention - after setting up the Azure DevOps setting, we can actually see packages published manually to that Nuget feed in packages tab in Orchestrator, so read is working.

What is not working is publishing to Orchestrator via an Orchestrator connected studio.

Upload package failed.System.InvalidOperationException: Failed to process request. ‘Bad Request - The request to the server did not include the header X-NuGet-ApiKey, but it is required even though credentials were provided. If using NuGet.exe, use the -ApiKey option to set this to an arbitrary value, for example “-ApiKey AzureDevOps” (DevOps Activity ID: 3B729A9C-B76D-4B1C-B1EA-034C9BBB818B)’.
The remote server returned an error: (400) Bad Request… —> System.Net.WebException: The remote server returned an error: (400) Bad Request…

1 Like

Anyone where this is running?

Hello @Gerardo ,

I tried the same setting in nuget.config but it is of no help. Can you please help me with the configuration in details.

Has Anyone got his working yet. I’m having the same issues with connecting to my nuget feed. I’ve tried V2 and v3 also with but my credentials and the alternate credentials.

It is working in visual studio

image

@tiberain - Were you able to get connecting to Nuget feed? I am also getting same error “Unable to load the service index for source”.

Hey @SridharI,

No it needs to be updated. I did found out that Uipath have updated there API connections sense this, so that add on won’t work currently, as password usernames is not used anymore.
Here is the link to that. Consuming Cloud API

Thanks! it work like a charm