Azure DevOps build generates library package without .dll file in it

UiPath Pack created nuget package for a library type project but does not have a dll file within it. It gives no error as well. This seems to happen only when I use “Invoke vba” activity. Otherwise it does the job correct.

Note : Locally when I try to publish on my machine, it creates nuget package correctly which works.

Please let me know how to solve this issue.

Hi @JDoshi

Could you provide some details about your specific setup?

I am using Uipath tasks for Azure DevOps in order to have CI-CD for my automation processes and all the libraries I use.

This worked smoothly until we used '“Invoke VBA code” in one xaml file of the excel library. On building it locally on machine it works and gives no error. While when i run my CI-CD pipeline, pack task used to generate the nuget package for Library project, generates nuget package with .dll file missing in it. It does not log any error in devops while executing task.

Since nuget package generated does not have .dll file in it, when it is referenced in automation project it gives error. I am saying it is because of “Invoke VBA code” as if I remove xaml having this activity from library project, then it builds correctly with .dll file in it.

Note : I am using Microsoft shared agent pool as my build agent. Below is my task steps

Hi JDoshi!
We managed to reproduce this issue by packaging a library created with the C# language.
For a library created with VB it does not happen.
Can you please confirm that the issue you are having is with a C# library project ?


Hi @Bogdan_Cucosel,

I am using VB library project.

Hi @JDoshi,

Could you please share a simple project with us ?

Thank you very much,

If you’re not feeling comfortable sharing it in public, feel free to send it to @Bogdan_Cucosel via a Private Message here on the Forum.

1 Like