Automation Hub, Import Pipeline Error

Hi all,

Im experiencing an issue when trying to upload CSV on Automation Hub under Import Pipeline. I followed the steps exactly however I keep getting the same error “A row has been detected with too many columns…”. This error keeps appearing no matter what I try even if there is only 1 comma or even 0 commas i.e. a blank file it always spits out this same error.

Can anyone please assist in trying to solve this problem.


Hello @Abdur_Hassan!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Curious if there was any resolution on this? I’m having the same issue.

Hi Andrew,

This error is encountered when the CSV that you are trying to upload does not match the template that the system expects.
To avoid this error, make sure you download the CSV template from the Import Pipeline page and refrain from adding/removing any columns from that template.

Hope this helps!