Automation for Salesforce

uiautomation
studio

#1

Hi

I was going through a UIPath tutorial for Salesforce GUI Automation.
My version of UI Path Studio is 18.1.2
The tutorial uses a different version.
I am trying to follow the steps in the tutorial to log into salesforce and navigate to a specific product.
After I am done, I save the recording but it is unable to execute it due to some error.

Here is the link for the tutorial:

Steps taken :-

  1. Create a Sequence Workflow
  2. Click the Record button.
    In the tutorial once this button is clicked a window pops up and it has 3 options.
    One of the options is ‘Open a web page before recording’.
    This options is not available in the version I am using.
    How do I replicate this step in the UI Path studio version that I am using?

#2

You shouldn’t need to do this. Just start the recording and do the activity (e.g. open the web browser and then perform the required actions).

The video may be using an older version of UiPath but all of the functionality is still there, some buttons have been removed as they were duplicated or redundant.

RD


#3

Hi RD,

Thanks for the response.

I tried as you said.

Steps taken :

  1. Opened the firefox browser.
  2. In UI Path Studio Clicked on Recording and selected Web
  3. In the firefox tab in the address bar I entered ‘test.salesforce.com
  4. I then chose the desired sandbox.
  5. Entered the password for it.
  6. Clicked the login button.
  7. Hit the escape button to exit the recording.
  8. Saved the recording.
  9. Then tried to run it.
    Received the following error message.

UI%20Path%20Error

Am I doing something wrong?


#4

Few things here

Are you able to run this in IE instead? UiPath works best with IE, then Chrome, then Firefox.

Either way you need to play around with Selectors - do you have a good understanding of how selectors work? If not then go through the academy. If you do then play around with UiExplorer to get some consistent selectors. Alternatively, if you’re still having trouble you may need to use alternative methods such as click text.

RD


#5

Hi RD,

Thanks again. Really appreciate you responses.
I will used IE and try out the same steps.
Also will try out the other tips you have given.


#6

Hi RD,

Tried to recreate the steps on IE browser.
This time it is moving ahead.
Thanks for your help.


#7

No worries. Don’t forget to like my post :slight_smile: