Automated typing in browser too fast, doesn't register the correct string

Hello guys!
I am pretty new to RPA with UiPath, still doing the Introduction to the RPA Developer Course.
I am doing one of the exercises in the course, the one which gets the current time in Bucharest (I believe you might be familiar with this).

I am following the steps precisely, however when robot is typing the search string “current time in Bucharest” into the Google Search bar (of Internet Explorer, that is what the video is doing), apparently the typing is too fast or something, because the search string comes up as “currnt tmen Bucast” or some other nonsense like that.

Can you tell me what is happening (maybe it is something to keep in mind for the future), and how can I solve it?

I did some digging around on my own, and I think I got it.

When performing a typing process, a Type Into process is created. If you click on this process, on its Properties (tab shown on the right), under Options, there is a DelayBetweenKeys option.

Apparently its default value is 10 milliseconds, which is a bit too fast. I tried 100 ms and it worked perfectly. 100 might be too much, so some trial and error until you find the fastest time which performs robustly would be the best option.

Hope this helps! :smiley:

1 Like

Do you guys happen to know how to change the default value of 10ms to something else?

1 - Open Browser + 10 milsec
2- Delay 00:00:05
3- Perform all the next activities

I don’t think you got my point…

Whenever I create a new Type Into process, I want the default delay to be different than the current default (10ms), meaning the delay between the keystrokes.

Or maybe can you be more specific? I do not see how to do what you did?

I think i do:

Option 1:

Option 2:

You clearly did not understand my point.

The default attribute of the Type Into activity, which I want to change, is DelayBetweenKeys.
In other words, I want to change the time it takes the robot from pressing one key, until pressing the following key.

Your solution, as I understand it, gives me the option to wait for a specific amount of time, before the string is typed.

And while this does not solve my problem, (DelayBetweenKeys does) I am asking if somebody knows a way to change this, so whenever I create a Type Into activity, 50 is the new default.

Thank you anyway, I appreciate your help :smiley:

What you whant is this ?


EXof word to type in to—> What

DelayBetweenKeys = the robot will write the “W” and wait 3 sec
the robot will write the “H” and wait 3 sec
the robot will write the “A” and wait 3 sec
the robot will write the “T”

Yes that is precisely what I wanted to change.

From the information that is displayed when you hover the mouse on that option, the default delay is 10 ms, and the maximum value is 1000 ms (1 second basically).

I was wondering if there was a way to change the default value, instead of changing it manually for every Type Into action.

Sry my info in print is rong you must not type 00:00:03 but ex: just type 50.

another why if not in CODE i dont realy now becouse for me it work

How … do you have Internet Explorer extention installed ?

I think IE extension was pre-installed… I did not download any extension for it.
Also, I wouldn’t be normally using IE, but I was simply following the video tutorial.

Anyway thanks for your help :smiley:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.