Authentication in Swagger not working, but working in Postman

Hi!

When I try to log in to Swagger through //cloud.uipath.com//***/swagger/index.html#/
with my Client ID & Secret, I am redirected to a orchestrator errorpage:
The error is: “An unknown error has occurred. (#200)”

It should be noted that I am able to authenticate using the credentials in Postman.
Does anybody know what could be wrong?

@Mikkel_Bank_Henriksen_MIK

in swagger you need not provide any just click on login and it should take the details

cheers

Hi Anil,

Thank you for the quick reply.
Unfortunately if I just click Authorize I get the same error :slight_smile:
image

@Mikkel_Bank_Henriksen_MIK

are you giving orchetsratorurl in the url of swagger?

and can you remove all the clientid and client secret if you have provided any…if not reload page it would get the values

cheers

Login first to the Orchestrator tenant. Then provide the Swagger url to the browser and you should be logged in automatically.

Hi again,

Yes I have already logged in to my tenant, I usually just access swagger by first acessing my cloud tenant and then correcting the URL to access Swagger.

I have tried to remove all client ID and secret:

But still get the same error.

I have also tried to reload the page, and even access by incognito, but the error still occours

Is your issue related to logging in to Swagger, or do you have problems with the Authorization feature?

Well I have access to the swagger page, so really think this is an issue with the Authorization feature. :slight_smile:

Are you providing a custom client_id value? I get the same error as you if I try to change it. It seems to work if I keep the default value.

Hmm I AM actually using a custom Client_ID value. bummer that the error message is non-descriptive :stuck_out_tongue:

When trying with the default value, I still get the error, but there is no Client Secret given by default. so I get the same error when trying to log in using the default value and no client secret.

Do you know where I can obtain the Client Secret that belongs to the default client ID?

Not sure if there’s a Client Secret involved actually.

.
About the PKCE flow:
Orchestrator - Accessing UiPath Resources Using External Applications - https://docs.uipath.com/

Okay, but no matter what I input in the Authorize menu, I get the error - What could be the cause of this?

Are you changing the scopes? Can you try with the prefilled client_id and checking all scopes? I also get the #200 error, if I remove all scopes and then click on Authorize.

I have tried both using no scopes, every scope, and a combination of the selected scopes.
Still get the same error :slight_smile:

Could this be an error in our set up or have anybody else experienced anything like it?

Hi, you need to ‘identity’ in the authorization URL and the token URL.
nice day

Can you put this Client ID bb55c0a2-d2cc-407a-9c1e-5f65e12eae77 in the Authorize without providing any Secret and then authorize?

image

1 Like

Same issue even after trying without client secret also

Hello there, same issue here

while connected to tenant orchestrator, i’m unableto authorize in swagger page,
I get ERROR 200 while clicking “Authorize” i’ve left everything standard ( client Id filled, no client secret )

Anyone has same issue ?

UPDATE : solved by clearing cache ( thanks to knowledge DB in UiPath before submitting ticket )