Attended robot does not work if RDP minimized


I am writing on behalf of my organization. We purchase a named licensed EE attended robot running on server. Robot is unable to perform if RDP windows gets minimized. It stops from click activities and type text.
What can we check to enable this? The processes it performs take a long time to complete.

Thank you for supporting

Hello @andrei.butnariu

the robot need the RDP UI because acting there is only possible on visual base…if nothing is visible it will not work.

1 Like

@RoboHeart is correct. Your automation is using the computer vision ui automation meaning it needs a visual of what is on the screen to determine selectors.

Your robot could run within the machine you are RDP’ed to instead and it would be able to process while the remote desktop is minimized, but you also would not be able to use it for other automation on the user’s PC.

1 Like

Hello and thank you for your response

The robot is installed on that server. However minimizing the Remote Desktop breaks execution of the workflow on another remote app. Now I know it would be possible to work with RDP window minimized, but what would it need? That addon with Remote Interractions or some registry fixes? Just to mention, execution breaks the second window gets minimized, so no policy or inactivity should be to blame here.

Best regards,

Oh ok so it is already running on the RDP server.

A quick search online indicates some Registry keys to update: Running Interactive Tasks in Minimized Remote Desktop Windows · Customer Portal

This should stop windows from switching to a headless (no-gui) mode when the RDP window is not visible.

Note that these need to be changed on the PC that is running the RDP client, not the server you are RDP’ed to.

Interesting, I will give it a try and post results.

Thank you a lot

Just stumbled upon this in the UiPath docs as well: Executing Tasks in a Minimized RDP Window


It is not working… It just freezes on minimization but also if I switch from non-full screen to windows mode. I am thinking it has something to do with the activities inside. If you got other ideas I can try them.

Did you notice that you have to do this: Executing Tasks in a Minimized RDP Window - on you OWN machine (and not the RDP).

I had the same issue, and used this fix - and it worked great after a restart.

1 Like