Attach Window activity works sometimes and not others

I have plenty of projects where Attach Window works fine.

I now have one that is nothing but an open google.com window that I am attaching to. And I add a “Type Into” activity that I point at the search bar and add some text. The program stops and then stops at the “Type Into” activity (no error message). Can’t figure out what is wrong here. The Google.com window is right behind the UiPath program.

image

I also tried looking at the selectors for both the Attach Window and Type Into activities and tried to take the “cls” attribute out and it still didn’t work.

The Attach Window selector:

image

The Type Into selector:

image

@tfs

Could you please give it a try with Attach Browser activity as you working with web application.

Not sure what you mean by that.

I create a project.
Open a browser to Google.com.
Add an Attach Browser.
I click the Indicate link and point at the Google web page.
I then add the “Type Into” activity.
I run the project, but it doesn’t seem to work.

I closed and reopened the program and it still didn’t work.

In the output, I am getting the following error (which I didn’t see it doing before).

I tried it again with a new browser window and recreated the project and it is pretty simple. Both selectors have the same “cls” (thought that might be the issue).

image