Attach Browser not working

I have used the Web recording for a web page to automate the google form, But while iterating the attach browser throws an error and my process gets stop.

make sure that both the attach browser and open browser refer to the same browser like IE or Chrome
check in the open browser with browser type property and make sure the same browser is referred by the selector in attach browser
And i would like to suggest if the process is going to be executed in the same page once after the browser is opened, there is no need of attach browser at all , as it is going to be performed in the same page,
and make sure that we return back to the first page as we are using loop here, for that atlast inside the for each row loop use a activity called Navigate URL and mention the URL that is mentioned in the open browser, which will make sure that we get back to the first page
Hope this would help you
Cheers @ramkrishna2k3

It worked, After completion of the First record I just clicked on refresh it tried to fetch the second record (half page completed), but I don’t understand why the click selector it getting error in 2nd record. When it worked in 1st record then why it is throwing on 2nd record. please explain to overcome the dynamic selector issue.:slight_smile:

1 Like

Kindly look at the selector for the first and second page in attach window activity
even try it manually, there will be some difference in the attributes that looks dynamic
change the attribute value with wildcard * and try buddy
you were almost done
Kindly try this and let know
Cheers @ramkrishna2k3

@ramkrishna2k3 Refer this thread it will work