Assistant says "could not start executor. wrong user name or password(0x8007052E)"

Hi guys,
I was blocked by a weird issue…I set up a robot account in OC, assigned access by providing user credential of my PC (windows 10 home edition) to this robot account, created a machine template with unattended robot license, then I installed unattended robot on my PC, linked with OC.
Next when I start a job in OC to run a process on this PC (just a message box, nothing else), I see failure message in both OC and assistant saying “could not start executor. wrong user name or password(0x8007052E)”, I made many attempts like removing and recreating everything, but nothing changed, all I know is, it works fine when I manually start this process in assistant, but not working if this comes from OC. I used my colleague’s PC as robot, input its credential, and start a job, it worked on his PC, now I’m confused what is wrong with my PC? Big thank you to any help.

Hi! Welcome to community!

Refer the below docs:


Hi NaNi,
I exactly followed that article and the only thing different from that is, I published my process to folder named “Dev Folder” instead of “Shared Folder”.

1 Like


Is it working now or still the same?

If you published to shared folder also you can give the robot access to that folder. and you can run the process from there.


It’s not working. I published the process to Dev Folder and assigned both robot account and machine the rights to this folder, that’s why I can select them when initiating a job, but each time when it runs, it says invalid user name or password.

Here’s the error message from my OC.

Please follow the below steps…

1.Tenant->Manage Access->Select your account->Edit->Robot Setup->Run Foreground automation

provide the following


Win+R → TYPE whoami->copy the code and provide it in Domain/Username

Credential store

Orchestrator Database


Your windows password

Credential type

Windows credentials

Then click on save.


Hi Nani,
Thank you for your detailed reply, but the place you mentioned has no option to choose foreground automation, I checked both my user account and robot account and find nowhere like you said. But I do find this in machine setting, it is process type, I chose “All” which should work for both foreground and background processes.

The pc that my robot account (unattended robot) is working on has pin and fingerprint login, I’m not sure if this is the problem since my colleague’s PC has no fingerprint function and it works just fine.

Probably you are using the Windows Home edition where Remote Desktop Server (used to connected to your unattended robot) is not available.

Hi Sonwman,
Thanks for your reminding, I was indeed using windows10 home edition but I switched to windows 11 and the problem still exists after reinstalling unatended robot.

do you have Remote Desktop Server there in Win11 ?

…you got me…so how can I check it? my assistant on this PC shows green which means connection to OC is working fine, and I assume that means all is fine, but it simply doesn’t run jobs.

From MS licensing page, RD is only available in Pro or Enterprise. You may be able to connect to Orchestrator, and you need RD to be connected back from Orchestrator.
Remote Desktop on Windows 11 - Microsoft Community

OK, I happen to find my pc with problem is using windows 11 Home edition and the RDP switch is disabled by default, I’m gonna upgrade it and give another try. But is this necessary for unattended robot?

I just upgraded windows11 home to professional, enabled RDP, disabled fingerprint login, but it still gave the same error message in OC saying “invalid user name or password”.


Could you please show us the flow here?


Hi NaNi, it’s no more than a message box … :joy:

:joy: :joy: :joy:

Since, We have the unattended license right…

Why can’t we connect with technical support team?

We may get the solution from the team…

Let’s check with the support team here: